Conky won't start after reboot

Hi everybody!. I have a problem with Conky. After the last Manjaro update, it doesn’t start on reboot or when I log out., but when I start it manually, runs well. What can it be? Thanks.

Just thinking is the start up script perhaps no longer called in autostart?

The following thread might be usefull

I found that adding a delay of 3 seconds to the conky autostart command was sufficient for conky to start correctly. ArchWiki suggests using 5 second pause

Conky has command option ‘-p’ (or ‘–pause’) to set delay time in seconds

  • Open the conky.desktop launcher in the autostart folder in a text editor
    nano ~/.config/autostart/conky.desktop
  • find the command to start conky - Exec=/usr/bin/conky -d
  • change it to - Exec=/usr/bin/conky -dp3
  • save changes, exit and reboot

That says the file:

[Desktop Entry]
Exec=conky --daemonize --pause=1

A 1 second pause is probably not long enough to load system functions monitored by conky

Thanks. I tried with more seconds and its the same :roll_eyes:

If you have not yet found the solution to getting Conky to autostart, here is something that worked for me. Found it in the Conky github forum at Conky does not start when set to autostart in KDE · Issue #1174 · brndnmtthws/conky · GitHub. Poster onurbbr offered a solution to make a change in your System Settings / Startup and Shutdown / autostart / Conky properties in the application tab. Change the command to this:

conky --daemonize --pause=5 >> /dev/null 2>&1

Note that onurbbr suggested a pause of 10; 5 seconds worked well enough for me.

The Exec command is not the same as it omits path to conky command
but it might not be a point of failure

Conky has an option to supress output/error messages

-q | --quiet   Run Conky in ‘quiet mode’ (ie. no output)

Exec=/usr/bin/conky --daemonize --quiet --pause=5

Thanks @nikgnomic. That’s fix the problem!.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.