conky startet mehrere instanzen

ich habe kürzlich die startweise meiner conky.conf abgeändert (autostart .desktop: conky -c "/home/user/.config/conky/LSD/conky.conf" --daemonize --pause=5).

das programm läuft zwar wie bisher, aber es startet teilweise 10 oder mehr instanzen gleichzeitig im hintergrund.

relevante conky.conf inhalt:

Summary
conky.config = {
	alignment = 'top_left',
	color0 = '#77e5e4',
	color1 = '#c5c5c5',
	color2 = '#c5c5c5',
	cpu_avg_samples = 1,
	default_bar_width = 30, default_bar_height = 8,
	default_color = '#c5c5c5',
	default_shade_color = '#000000',
	double_buffer = true,
	draw_shades = false,
	font = 'Fira Sans:size=9',
	gap_x = 100,
	gap_y = 100,
	imlib_cache_size = 0,
	minimum_width = 280, minimum_height = 0,
	net_avg_samples = 1,
	no_buffers = true,
	override_utf8_locale = true,
	own_window_argb_value = 0,
	own_window_argb_visual = true,
	own_window_hints = 'undecorated,sticky,below,skip_taskbar,skip_pager',
	own_window_transparent = false,
	own_window = true,
	own_window_type = 'dock',
	total_run_times = 0,
	update_interval = 1,
	use_xft = true,

};

conky.text = [[
${goto 180}${color0}${font Fira Sans:style=bold:size=13}${voffset 35}${exec whoami}
${voffset -30}${font Fira Sans:style=Bold:size=12}${color}${goto 40}${uptime}
${goto 80}${color1}${font Fira Sans:style=Bold:size=12}${color1}${sysname}${color}${font}
${voffset 40}${font Fira Sans:style=Bold:size=11}${goto 128}CPU0${goto 218}GHz
${font Fira Sans:style=Bold:size=11}${goto 128}${cpu cpu1}%${goto 218}${freq_g}
${voffset 40}${font Fira Sans:style=Bold:size=11}${goto 88}CPU1${goto 175}${font Fira Sans:style=Bold:size=11}CPU2
${font Fira Sans:style=Bold:size=11}${goto 88}${cpu cpu2}%${goto 175}${font Fira Sans:style=Bold:size=11}${color1}${cpu cpu3}%
${voffset 40}${goto 45}T°C${color1}${goto 128}CPU3
${goto 45}${font Fira Sans:style=Bold:size=10}${acpitemp}°C${goto 134}${font Fira Sans:style=Bold:size=11}${cpu cpu4}%${font Fira Sans:style=Bold:size=11}${color1}${font}
${font Fira Sans:style=Bold:size=11}${font}
${voffset 10}${goto 90}${font Fira Sans:style=Bold:size=11}RAM
${goto 90}${font Fira Sans:style=Bold:size=11}${memperc}%
${goto 10}${color0}${voffset -230}${font Fira Sans:style=bold:size=30}${time %H:%M}${font}
${image ~/.config/conky/LSD/LSD.png -p 10,0}



]];

bei der suche nach lösungen bin ich bisher nur auf tipps zum starten mehrerer instanzen gestoßen :crazy_face:

kann man das irgendwie eingrenzen, denn auch die lesbarkeit der dargstellten werte leidet darunter.

Hallo xtristanx,
ich sehe nichts, warum conky mehrere Instanzen starten sollte. Aber leider lässt sich das nicht nachvollziehen, da dein Code nur ein Fragment ist. Deshalb starte mal conky von Hand aus der Konsole
conky -c "/home/user/.config/conky/LSD/conky.conf" --daemonize --pause=5
daraufhin muss ja eine Ausgabe in der Konsole kommen, irgendwie sowas:

conky: desktop window (fd) is root window
conky: window type - normal
conky: drawing to created window (0x4000001)
conky: drawing to double buffer
conky: forked to background, pid is 14336

poste das bitte.
Und auch die Ausgabe von
ps -fC conky

viele Grüße gosia

ich auch nicht :smile: im ernst, gut möglich, daß es auch gar nichts mit conky zu tun hat, sondern viel globalerer natur ist.

einige wenige programme nisten sich nach dem ausführen nämlich doppelt in den ram. beende ich diese instanz nicht (nach dem schließen des tools), werden sie beim nächsten boot automatisch geöffnet!? war mir bisher zu obskur, um daraus nen extra thema zu machen. schätze, jetzt ist die katze aus dem sack.

wie auch immer, hier die infos:

Summary

$ conky -c "/home/user/.config/conky/LSD/conky.conf" --daemonize --pause=5
conky: desktop window (200000f) is subwindow of root window (133)
conky: window type - dock
conky: drawing to created window (0x3600002)
conky: drawing to double buffer
conky: forked to background, pid is 9848

$ ps -fC conky
UID PID PPID C STIME TTY TIME CMD
user 9848 1 1 22:07 pts/1 00:00:00 conky -c /home/user/.config/conky/LSD/conky.conf --daem

gute nacht :wink:

Hallo xtristanx,

Naja, das ist wirklich sehr obskur. Jedenfalls dann, wenn Du deinen Rechner "richtig" runterfährst = "ausschalten" -> vom Strom trennen.
Es gibt aber bei xfce eine Möglichkeit, wenn man dort beim Abmelden "Sitzung beim Abmelden speichern" (oder wie das genau heisst) auswählt, dann startet Conky schon mal doppelt.
Keine Ahnung ob sowas bei deinem KDE/Plasma auch existiert.
Jedenfalls sehe ich bei deiner Ausgabe

nur einen Conky und zwar genau den, den Du mit Hand gestartet hast (PID 9848).
Aber wie gesagt, lass doch mal den ganzen Code deiner conky.conf hier los, da kann man das nachspielen.

viele Grüße gosia

du hast recht, reboot war gemeint.

die option von der du sprichst habe ich auf die schnelle in kde nicht gefunden (und auch nicht gesetzt/verändert).

das ist richtig, mußte aber zuvor 4 instanzen beenden. die anzahl ist wie gesagt sehr willkürlich, manchmal nur 2, waren aber auch schon über 10 gleichzeitig. was das ganze begünstigt kann ich leider nicht sagen.

die komplette conky findest du jetzt in post #1.

ich kann nicht mal sagen, ob das mit conky ev immer schon so war? es fiel mir halt jetzt auf, da ich das startverhalten geändert habe und extra darauf geachtet habe.

habe nocheinmal einen test mit clipgrab gemacht (habe es erneut installiert) und es wird auch nach einem kaltstart autogestartet. das ganze ist mir auch schon mit anderen programmen passiert (sporadic autostart of K3B), bei diesem ist es aber absolut konstant.

es genügt nicht, das programm zu schließen, ich muß die instanz in ksysguard beenden, ansonsten wird es immer wieder autogestartet!

Systemeinstellungen -> "Starten und Beenden" -> Arbeitsflächen-Sitzung -> "Bei der Anmeldung". Hier gibt's "Mit leerer Sitzung starten", aber eben auch "Vorige Sitzung wiederherstellen".

1 Like

tausend dank, das scheint es gewesen zu sein :sunny:

voreingestellt ist bei mir seltsamerweise: Vorige Sitzung wiederherstellen -- jetzt habe ich es abgeändert auf: Mit leerer Sitzung starten.

conky hat nach neustarts nur noch eine instanz & clipgrab trotz bestehender instanz nach beenden keine autostarts mehr.

Schön, dass das gefunden/behoben ist.

1 Like

wenn das default ist, frage ich mich, warum nur so wenige leute von diesen problemen betroffen sind?

Forum kindly sponsored by Bytemark