Conky not starting after Lua 5.4 update - ('.')(",)

you can do that by using the convert.lua script in the /usr/share/doc/conky* folder on your config (maybe backup it before running the convert)
syntax: ./convert.lua /path/to/your/config/file

1 Like

I just have a conkyrc in /home. Can I use for?

Ok I just needed to give execute permission to the lua script and its worked. Thx for the help.

1 Like

Interesting - that’s the script I copied and pasted to my /.local/bin folder - non destructive way to test and no root permissions required :wink:

1 Like


Since 2013, across 4 distros. Although to be fair, I don’t want/need/like all the fancy eye-candy.


Stick this in your ~/.local/bin folder

Worked for both of my ancient scripts:
Not the clock though - that’s KWIN effect ‘osd clock’.

Configurations · brndnmtthws/conky Wiki · GitHub
Converting old configs to 1.10
The script is not always flawless. You might need to tweak it somewhat if it does not work. Otherwise, the script should already take care of the more annoying and tedious work (i.e. syntax change) for you

so may need to use style guidelines from section 1.10 and later versions to edit conky.conf

save file to ~/.config/conky/conky.conf
Where is conky.conf?

@woistmeinauto would you be possibly be using conky-manager?
that is old and buggy and i would not expect configurations have been updated. not much activity on Launchpad site
Unable to read conky 1.10.x configuration file

1 Like

It worked for me but only for two conkies, the bigger part of my configs files just could’not be converted.
Well, enough for today. :cup_with_straw:
Btw, it works only with Conky (1.11.5), not with Conky-lua-nv, right?! (Or it was my fault again?)

It works for more conkies (even four of my collection now!), but (for me only) in the "conky (1.11.5) + its convert.lua " combo. Conky-lua-nv doesn’t work at all.

you can install ‘lua53’ beside ‘lua54’ … I did it so and conky works again like before.

Installed lua53 (only forgot to mention it )
Still, convert.lua can’t convert all of them.
Well, never mind, so far so good.

also possible pamac build conky-manager2-git


convert.lua AND conky-manager2-git works… finally!


I am not into all those fancy but Conky has not glitched a bit since I installed it on my laptop 2 years ago.

1 Like

2 posts were merged into an existing topic: Just help me set up Conky please and I dont have ~/.conkyrc

Flipper, i love this conky! Did you make it, or can i find it somewhere to download? I need this in my life :slight_smile:

It came from here (slightly modified)

Ahh that’s beautiful, thank you so much!

i love this community, cheers guys :slight_smile:

for those who cannot run the script, simply download the Githubfile, install lua on your laptop and run

$ lua convert.lua /path/of/old/lua /path/of/new/lua

and delete the previous one

1 Like