Confused on the new card

Hi all,
So…I did what I normally do not do: spontanuously change a graphics card.
As some may have gathered, I know a lot (never enough) but have very little self confidence.
So…clean breath and in went the card…
I started up and…it worked! I had a display!
Then, I went on to gather yet more courage and was ready to face the next hellhound: the driver.
And…mhwd say…“nah, ya already got all ya need”…
So, here is inxi’s view on things:

System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.21.2 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: Hewlett-Packard product: HP Z400 Workstation v: N/A serial: <filter> 
           Mobo: Hewlett-Packard model: 0B4Ch v: D serial: <filter> BIOS: Hewlett-Packard v: 786G3 v03.12 
           date: 09/13/2010 
CPU:       Info: Quad Core model: Intel Xeon W3565 bits: 64 type: MCP arch: Nehalem rev: 5 L2 cache: 8 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25607 
           Speed: 1600 MHz min/max: 1596/3193 MHz boost: enabled Core speeds (MHz): 1: 1600 2: 1600 3: 1600 4: 1600 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] vendor: XFX Pine 
           driver: radeon v: kernel bus ID: 0f:00.0 
           Display: x11 server: X.Org 1.20.10 driver: loaded: ati,radeon unloaded: modesetting 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 5.9.16-1-MANJARO LLVM 11.1.0) v: 3.3 Mesa 20.3.4 
           direct render: Yes 
Audio:     Device-1: Intel 82801JI HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Broadcom NetXtreme BCM5764M Gigabit Ethernet PCIe vendor: Hewlett-Packard driver: tg3 v: kernel 
           port: d0c0 bus ID: 01:00.0 
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:1f.2 
Drives:    Local Storage: total: 1.82 TiB used: 937.33 GiB (50.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD20EFRX-68EUZN0 size: 1.82 TiB 
Partition: ID-1: / size: 122.54 GiB used: 18.43 GiB (15.0%) fs: ext4 dev: /dev/sda5 
           ID-2: /home size: 1.65 TiB used: 918.89 GiB (54.5%) fs: ext4 dev: /dev/sda6 
Swap:      ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%) dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A gpu: radeon temp: 55.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 194 Uptime: 29m Memory: 7.76 GiB used: 3.18 GiB (41.0%) Init: systemd Compilers: gcc: 10.2.0 
           clang: 11.1.0 Packages: 1431 Shell: Bash v: 5.1.0 inxi: 3.3.01

I assume…I have the correct driver.
I only have the “install the opensource driver” in manjaro-settings, as I assume (re)installing the proprietry driver is useless as it’s already in there, so that button should not show…
Am I correct in my assumptions that the proprietry driver is installed?
:hugs: Melissa :hugs:

Congrats! What’s the output of mhwd -li?

This is Southern Islands / Sea Islands

You probably want to swap to AMDGPU for this. I don’t know if we have the support enabled in our kernel, but you can try it.

The only proprietary driver for AMD are in AUR, which is AMDGPU-PRO

Edit: This card is Caicos, not Southern Islands.

Ah, no cigar, I guess:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Okay, now…this does confuse me… :confused:

Why would you want to install proprietary software, anyway? Defeats the purpose if you ask me :man_shrugging:

Well, I come from an nVidia (hope I spell that right) FX1800 Quad. But…no more drivers. After an update, I was no longer able to use the system (I had to reinstall). Then I noticed freeze-ups, possibly (very likely) due to Nouveau. After some advice, I decided to go for a newer card with an AMD instead the nVidia, this so I can use decent drivers…

1 Like

Issue is that you obtained a really old AMD GPU that was originally only supported by AMD Catalyst and Radeon drivers.

Best GPUs to buy are Radeon R5/R7/R9 300 series (2015) and newer. That is when AMD open source GPU drivers have gotten very good. Preferably the R5/R7/R9 400 series (2016) and forward.

At least there is some experimental support that I’ve read gotten better that you can activate for your old GPU. I have no experience in this matter for this one though.

This is a 2010 GPU

If I could talk to my ‘past-self’, I’d tell it to check linux-compatibility first before getting my hands on any hardware… :grinning: (had my fair share of nvidia myself…)

I guess so, but…that’s all I could afford :wink:

You should try these subreddits in the future (depending where you live). I’ve gotten really great prices for stuff before:

1 Like

Yea. There are some things to consider:

  • the width of the slot involved, I can only use one…
  • the power of the box…
  • the connections. I have a PS2/VGA kvm here, I’d have to toss all my hardware if I wanted to use a brand new card…
    as I mentioned, there’s only this much cash around here

I was rather talking to myself - no pun intended :slightly_smiling_face:
You made a pretty good choice as far as I can tell, if everything’s working smoothly…

1 Like

Eh…it’s a simple story
I am a single-income household. And some cash has to go to wall paper and such…so I need to spread the costs a bit :slight_smile:

Sorry, I was wrong. Since your card is Caicos, it’s literally just 1 generation behind from Southern Islands. There is no amdgpu support for your card.

You’re stuck with the radeon driver

Which is…okay, I guess…
I experience a smoother screen, I’ll see if any freeze-ups occur…I hope not… :wink:

I would always recommend to at least try wayland, since xorg is a dinosaur and seriously flawed security-wise.

Wayland on the otherhand has its teething troubles (personally never had any problems, though), but if it works for you (some programs still don’t support wayland), you will have the smoothest visual experience one could wish for…

(Manjaro) Gnome defaults to wayland, but can be run under xorg as well, if you want to give it a shot via live iso.

1 Like

Wayland :thinking: - I need to look into this. I suppose (reading the post) that is will replace Xorg is I install it…

You could run both on the same machine, only some DEs will only work with either xorg or wayland.

And here I am learning things again.
I run KDE, tomorrow, I’ll see if I can install Wayland (since I’m playing around anyway :rofl: ) and see what it does :slight_smile:

1 Like