Configuring new Build - any known issues?

Hi All,

After 8 years I’m going to give my main PC build an upgrade and although it’s primarily for work I do enjoy gaming on it, even in it’s current state. What I’m hoping for, of course, is much increased performance with the new build.

The one thing that really annoys me about Manjaro at the moment is the way the Nvidia drivers are the cause of most of my headaches, especially after updates. Am I going to be facing the same thing on a newer card?

The build is being specced quite heavily based on what’s available rather than my ideal components and the CPU will certainly be getting an upgrade once availability increases over the next few months but from a work perspective I need to increase productivity quickly and that means getting a machine this week. I just want it sanity checked by those on here first to see if there’s any known issues I’m heading into.
I like to keep my hardware for it’s usable life so need to make sure I’m getting it right.

General build spec:
ASUS AMD Ryzen X570 ROG Crosshair VIII Hero WiFi
AMD Ryzen 7 5800X, AM4, Zen 3,
Gigabyte AORUS NVIDIA GeForce RTX 3080 10GB XTREME

Many thanks in advance!

This is not a Manjaro issue; this is an Nvidia issue. And yes, if you’re sticking with Nvidia, then you are going to keep running into the same problem, because Nvidia insists on keeping their drivers proprietary. That means that the source code is not available, and on top of this, that nobody has the legal right to modify the drivers even if they had the source code.

With Nvidia, you are subject to their corporate decisions, and there’s no way around that. My advice would be to go with an AMD GPU if you want to use this machine for gaming.

1 Like

Hi Avionyx (and potential future readers and repliers),

I just had (and solved, though I do not fully understand the cause yes) a problem with my new build.

Specifically with the cpu which is the same as the one you want, and I think it persists on at least AM4 in general.

On kernel 5.9 I get no readings for the sensor on k10temp(, or rather it always says 0°C)
I did not have this issue a week before(I had to reinstall in the meantime, but that was my fault).

After I tried some things, which were not succesfull I remembered, that I had not switched the kernel yet.
And that solved it. I am going with 5.10 now(as I planned anyway).

Apart from that I’ve got no problems whatsoever.
My remaining setup is
ASRock B550 Steel Legend
and
(I believe MSI) NVIDA Geforce GTX 1080 (whatever).

I will buy a new gpu in a year or so I think. Hopefully, it will be available by then.
As such I wish you the best of luck (and success of course) to get a 3080.

Additionally: I use an NVIDIA because of Cuda and plan for Ray-Tracing. Unfortunately I know of no alternative for Cuda from AMD, and as far as I know they can’t compete in Ray-Tracing(and don’t have DLSS).

Thanks for the reply!

I went ahead with the build as planned and have had it running successfully for a couple of weeks now. I’ve had absolutely no issues with anything so far and the gaming experience has been just as good as the productivity.

The temp sensor issue you mention I also had and ended up posting about it elsewhere but it was well documented. I understand that if you upgrade to Kernel 5.11 on a Zen3 processor at the moment you’ll lose voltage monitoring as per this article: Linux 5.11 Drops AMD Zen Voltage/Current Reporting Over Lack Of Documentation - Phoronix

Decided to take the risk for a Monday Morning. Changed to 5.11 and absolutely no issues, get full temp monitoring available it would seem anyway so very happy.