Configuration aborted. Username contained invalid characters. Restarting OEM script

I’ve bought today a brand new Raspberry Pi 4B 4 GB RAM after my old one died and, after flashing the latest Manjaro Minimal ARM build for the RPI 4, downloaded from the official website, using BalenaEtcher, sshing as root to my RPI results in the following, seemingly endless, loop:

$ ssh root@
Welcome to Manjaro-ARM
Last login: Sun Aug  8 18:57:55 2021 from
tput: unknown terminal "xterm-kitty"
tput: unknown terminal "xterm-kitty"
Argument "" isn't numeric in numeric eq (==) at /usr/bin/inxi line 464.
tput: unknown terminal "xterm-kitty"
tput: unknown terminal "xterm-kitty"
Argument "" isn't numeric in numeric eq (==) at /usr/bin/inxi line 464.
/usr/share/manjaro-arm-oem-install/manjaro-arm-oem-install: line 75: /sys/devices/platform/bootsplash.0/enabled: No such file or directory
loadkeys: Unable to open file: Error opening terminal: xterm-kitty.: No such file or directory
'xterm-kitty': unknown terminal type.
==> Configuration aborted. Username contained invalid characters. Restarting OEM script...

I had to use ctrl + c to cancel and I’ve shut down my RPI.
This happens both with terminal kitty and urxvt.

Everything here is brand new so I’m sure it can’t be a problem in my end. How should I start debugging this issue?

A few things I would like to ask that are unrelated to the problem at hand:

  • Wasn’t the minimal version smaller? It’s currently taking 1.8 GB of space, which I think it’s too much compared to what I thought it took, and I’m pretty sure its larger than a minimal headless debian install, which according to the wiki is at most 971 MB.
  • Does this initial script allow me to setup btrfs? My goal was to have the root system of the RPI 4 as btrfs, to allow me to perform periodic snapshots and easily restore my system in case of software or hardware malfunction (e.g.: broken updates would revert to previous snapshot, busted SD card would buy new one and flash previous snapshot), is there a recommended way of doing so? As soon as I have this up and running I will be following this guide.

First of all, what image exactly did you download? Filename, please.
Second of all, what do you mean by this:

We use bash in our images. So try connecting to ssh via bash, like bash ssh root@ to see if that makes the output better.

The Minimal version still has some things installed, that we find useful. Like pacman-mirrors (which pulls in python etc) and some might even also have linux-firmware, which is a pretty big package. It also has around 300MB of empty space by default.

No. The OEM setup just sets up username, passwords, locale, keyboard layout and such. The standard filesystems on the pre-made images are fat32 for /boot and ext4 for /. If you want it different, you need to create your own image with buildarmimg from the Manjaro ARM Tools.
But the easiest is probably to use our manjaro-arm-installer to set up an install with btrfs on the SD card from the get-go.

It was Manjaro-ARM-minimal-rpi4-21.08.img.xz

I mean that I tried both sshing with kitty and urxvt.
However I just installed terminator and when I ssh using it, the OEM script is working. It’s probably some incompatibility with these terminals, since I tried using bash in kitty and it didn’t work either.

Okay thanks for the information!

I had heard of that tool before, but I never really used it, I’m going to try to convert ext4 to btfrs and if it fails or I think that something might be wrong I’ll give this one a shot.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.