Computer won't boot after Nvidia driver install

Hello, Im a user of Manjaro since May of this year. I use a dual boot with Windows on my laptop, that has a Geforce 750M from 2013 or so.

Recently, some horizontal lines started appearing on my monitor. As they also do on Windows, I thought that this was likely a hardware issue, but decided to try Nvidia’s driver on Manjaro anyway.

I ran the following command:

sudo mhwd -i pci video-nvidia-450xx

which I found on Manjaro’s wiki, but I am not allowed to link the page here.

and proceeded to reboot as the page instructs me to.

However, I am now unable to load Manjaro’s GUI properly, as I get only this message on the upper left corner:

[FAILED] Failed to start Simple Desktop Display Manager

I’d just like to return to a normal loading and do not need to keep Nvidia’s driver. How could I do this?


Here is where the support stops for that GPU

So, you will have to probably use
if your laptop has hybrid GPUs
or simply
if is not a hybrid GPUs laptop.

So, from TTY remove the driver you installed, and install the good one.


I have the exact same issue i.e. booting fails with:

[FAILED] Failed to start Simple Desktop Display Manager.

This is with an ATI Graphics card (AMD Radeon™ RX 5500 XT), running on an ASUS mobo (i5-8500, 16Gb RAM) same error message as above. I had to install openSUSE to get everything to work, but would prefer to use manjaro if possible.

What information do you need from me to be able to investigate, please?

:+1: Welcome to Manjaro! :+1:

Please read this and create a new topic and provide this information as your issue uses completely different hardware compared to OP.

Thank you for your cooperation and understanding. :+1: