Computer always boots two hours before correct time

I use Manjaro/Windows dual boot. On both systems, my computer always boots with a time two hours before the correct one (if it is 14h00, it boots as 12h00). As I leave the time to be set automatically by the OS, both get the correct time after a few minutes running.

What’s going on? Could it be that the boot time is always being interpreted as UTC? Can I configure it somehow so that Manjaro interprets the time correctly from the outset?

This might help


I solved it in another way from the post linked by moson by installing an application to Windows that checks and sets the correct time to Windows at start-up immediately after the Internet connection comes online. The system clock is in UTC and my Windows is told not to touch it. There were several varieties of small applications that did just that, which I found quite easily with a search. As usual, there are many ways to go about this issue.

1 Like

Thank you for your answers! The problem is, this happens even if I stay for days without logging on Windows at all - Linux is somehow always unwinding local time by two hours.

Obs. I might mention that this started happening after I ran Linux Mint on my machine from a USB drive (but did not install it). Manjaro was already installed.

I have the opposite problem. At boot my clock is one hour forward. After a couple of minutes it resets to the correct time. I just live with it. :crazy_face:

Maybe a BIOS setting?

1 Like

On top of what @Falav said what kernels are you guys running? I’m trying to think of what’s responsible for setting the clock the only thing I can come up with is the kernel because I remember from once when I looked it up a long time ago the clock is a component in the CPU.

I did a little research on this it seems to be a bios setting as @Falav said.

The Arch wiki contains a very informative article on the hardware clock