Compositor stops working, needs to be manually re-enabled

Hi all,

So im pretty new to manjaro, have been a long time mint user, and switched over because i wanted more control and customization.

One big issue i am having is after a while the compositor seems to stop working (desktop effects stop working, screen tearing all over) and i have to manually disable/enable it to get it back working, only for it to fail again later.

Heres some info

System:    Host: -pc Kernel: 4.19.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.2 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Crosshair V Formula v: Rev 1.xx serial: <filter> BIOS: American Megatrends 
           v: 1703 date: 10/17/2012 
CPU:       Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 72520 
           Speed: 4524 MHz min/max: N/A Core speeds (MHz): 1: 4524 2: 4524 3: 4529 4: 4524 5: 4528 6: 4531 7: 4531 8: 4529 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 06:00.0 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting,radeon 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.27.0 4.19.56-1-MANJARO LLVM 8.0.0) v: 4.5 Mesa 19.1.1 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 06:00.1 
           Sound Server: ALSA v: k4.19.56-1-MANJARO 
Network:   Device-1: Intel 82583V Gigabit Network vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: d000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 4.91 TiB used: 1.28 TiB (26.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD6400AAKS-22A7B2 size: 596.17 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD6400AAKS-22A7B0 size: 596.17 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD6400AAKS-22A7B2 size: 596.17 GiB 
           ID-4: /dev/sdd vendor: SanDisk model: SSD PLUS 240GB size: 223.58 GiB 
           ID-5: /dev/sde vendor: SanDisk model: SSD PLUS 240GB size: 223.58 GiB 
           ID-6: /dev/sdf vendor: Western Digital model: WD30EZRX-00DC0B0 size: 2.73 TiB 
Partition: ID-1: / size: 210.40 GiB used: 112.80 GiB (53.6%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 45.0 C mobo: 31.0 C gpu: amdgpu temp: 41 C 
           Fan Speeds (RPM): cpu: 2156 fan-2: 0 gpu: amdgpu fan: 1051 
           Voltages: 12v: N/A 5v: N/A 3.3v: 3.22 vbat: 3.36 
Info:      Processes: 289 Uptime: 2m Memory: 15.63 GiB used: 3.23 GiB (20.7%) Init: systemd Compilers: gcc: 9.1.0 Shell: bash 
           v: 5.0.7 inxi: 3.0.34 

1 Like

Try switching your compositor from OpenGL 2.0 which I believe is the default. To OpenGL 3.1 or even xrender. See if behaves.

1 Like

Forgot to mention i tried that and nothing :confused:

1 Like

Ok, add a new user and login to that account and see if it continues.

Did you check journal for any errors?

I don't use AMD, but is this normal?

driver: amdgpu FAILED: ati unloaded: modesetting,radeon
1 Like

Yeah, mines the same.

No im not sure how to do that. I will try a new user account now

I think i may have narrowed down the cause, it seems to disable when i launch rocket league on steam, but not re enable when i close it?

If that's the case, then after you close rocket league try Shift+Alt+F12 and see if Compositing will start again.

Yes it does start up again, but should it not re enable automatically?

edit

also noticed on reboot it does not start up automatically

KDE has settings for this:

Can you verify that these are not the reason?

1 Like

That's kwin lowlatency

I recently replaced for testing, yes... but I'm pretty sure those options always existed.

ex:

Third one does not on regular kwin
Suspend compositing for full screen windows.
I also switched to lowlatency.

Well, ok maybe - thanks for the correction - the other two are still pertinent nonetheless.

im gonna give this lowlatency a go

If the compositor is kwin, my experience is, this is some bad (corrupted) config, so find some kwin or plasma configs, delete or rename them (bringing back defaults), see if the issue still exists (usually not), then personalize your desktop again (usually the problem is gone and desktop is stable).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by