Compositor keeps on crashing after waking from sleep post update

After the most recent update to Plasma 5.21, I’ve come across a rather annoying issue.

When I wake my computer up from sleep, the compositor has stopped working. I need to manually restart it every time

Needless to say this is rather cumbersome and annoying.

Is anyone else having this issue? Is there a way to fix this?

Edit: My compositor settings are at default, I haven’t played with them since installation.

Hi @helpcomputer,

I also had a problem with this and couldn’t find a solution. In the end I made a shortcut that quickly restarts the compositor, so that I didn’t have to go to System settings to do it every time.

The shortcut is simple. I created a shortcut in my dock so that I can easily click it, but you can assign it to an alias just as easily. The command is:

kwin_x11 --replace  >/dev/null 2>&1

I used it while typing this, and it works like a charm.

Hope this helps!

1 Like

Thank you for that suggestion. There’s also a keyboard shortcut alt+shift+f12 to restart the compositor.

I’m using that in the meantime; but again, its cumbersome and I’m hoping for a more permanent “proper” solution.

You’re welcome!

Yes, I know about the shortcut, but for me, personally, the shortcut worked better.

I’m hoping for the permanent, proper solution as well.

'Tis but a workaround and not a solution.

1 Like

Just as an update, I have two discoveries to share:

1.) Upon waking from sleep I have a notification from Kwin saying:

“Desktop Effects have been disabled by another application.”

I have no idea what that application might be or why its disabling destkop effects.

2.) I left a youtube tab open on firefox last night; this morning for whatever reasons, that prevent Desktop Effects from being disabled.

If anyone has any insight to offer, I’d really appreciate it.

Thank you

  1. If that happens, you can press Ctrl+Shift+F12 to restart the compositor.
  2. No idea, sorry. :stuck_out_tongue:
1 Like

I wonder if this is related to my issue: when plugging in another monitor, in 90% of cases composition is tuned off, also with this annoying “Desktop Effects have been disabled by another application.”

I can’t say; I only have a single monitor setup. But I do want to point out that I only began having this issue after 5.21 update.

Just as an update, the compositing problem still persists after the 5.21.2 update

I also don’t get much of response about my similar bug. Something is turning the composition off, but I have no idea what. My guess it’s Xorg, but why? In your case it could be something different but Xorg is always a suspect ;). Maybe I should look through xorg logs? Hmm…

Isn’t some of new settings experimental? Problem is that if you switch it without restarting even plasma, not just compositor, it can be automatical by now, there’s a huge problem, there’s old variable and settings are just temporary, because Qt sucks, and battle of those two states is improperly managed.

You have a virus, that’s turning of your composition settings, or those porks if they have now have something like two settings managers that battle for your attention which one of is having 0 settings because it’s loading folder have been deleted.

I’ll gladly share my xlogs if you think it’ll help

Therea rejust two issues

1.) I don’t know how to make snese of them

2.) Tied to 1, I don’t even know where they’re located.

Edit: Under KSystemLog, there’s a tab that says x.org log. Would that be it?

Edit 2: Here is the log for I THINK the past 3 sleep/wake cycles. It doesn’t seem to say anything really, just a lot of resolution stuff (which confuses me because I don’t change myr esolution)

1 Like

I just wanted to add that I also have issues with compositor since yesterday. There were no new updates (except Firefox and Chrome), I didn’t install anything and didn’t change any settings. But after that happened I tried changing rendering to OpenGL 2 (not working) and to XRender (comp didn’t turn off, but in general it didn’t work fine).
I’m also using Krohnkite for window’s management and maximise window options stopped working also. When I try to use it I can see a window going max just for a fraction of a second and then going back. So my guess is it’s a problem with compositor.