Compiz-easy-patch removed from repos

@wongs yes, although users of compiz 0.8 are welcome to comment the package that they use

I rather recommend to go a similar way as the Manjaro Sway Project went. Having a CI with Github Package Repo added to their Development ISOs. Most likely we can help to achieve a similar way. Having compiz-easy-patch back in our repos makes for me at least no sense …

With all respect, can somebody please explain to me why exactly it is a problem to have Compiz in the Manjaro repos? Compiz has been in the Manjaro repos for years. It seems to me that creating new repos and/or develpment isos would be a lot more work than simply updating the existing package from time to time? Considering the fact that there obviously aren’t a ton of active forum members using compiz here, and I get that, but why make the few who use it have to jump through hoops to keep it going when there is already a working system in place?

One last thing, I’ve been using Compiz for years and this morning I updated my computer to have everything I do put on hold because my DM is no longer working. No warning, nothing. Just woke up, updated my computer and now I can’t work because none of my screens are working and I have to figure this out. At the end of the day I’ve been using Manjaro for many years, I have it installed on many of my own computers and some of my customers computers and every one of them has compiz installed. Now I wake up this morning and simply update my computer to find that I am now screwed and cannot do my work for the day. Maybe some of that blame falls on me for not taking the time to read all the update notes, but all of this could have been avoided with a few lines of code in an already existing system that works.

Hi Everyone,

I’m making this post because the compiz package seems to have lost support and I want to ask the community here to help get it back online. Compiz is an amazing tool and honestly I’m surprised more people aren’t using it.

As far as I can tell @lectrode has been trying very hard to keep this alive as well as @linux-aarhus and many thanks to you guys for your help. Here you can see how they offered to help keep it alive by creating the compiz-easy-patch when the original compiz-manjaro was removed.

I’m asking all you guys out there who use compiz to please help encourage the package managers here to keep supporting compiz. I am also willing to help, although not a developer I’m sure I can learn how to do some of the tedious things to help the packaging process.

Please reply to this post and/or go over to the codeberg page and comment there to let them know you are still interested.

Here is the link for the Codeberg page for compiz-easy-patch where the issue was mentioned they are removing the project from manjaro…

I’m tagging a few of you guys who I know have been using compiz. Please comment and let Manjaro know we still use Compiz. Thank you all!

@alexandrosmc @zaileion @farhad69 @Drone4four

I use Compiz from the beginning, every day, and I take a little time to figure out why it doesn’t work after the upgrade. Hopefully after see the protobuf issue and reading the archlinux wiki (still the best source of information) I jump in the forum and discover this thread.

Although the project is currently quite inactive on the launchpad from ubuntu, the product is rather mature and stable since a long time. So, I’m little sad to see the lack of support.


welcome to the forum :slight_smile:

thank you for making your voice heard. our best bet is likely showing manjaro devs how many people use the most feature-full X11 compositor out there.

1 Like

I have been using Manjaro Compiz (easypatch)/Cairo Dock now for about two years with out any compiz problems. It has been my main driver till it broke yesterday. I posted my request for help with the XFCE support before I found this post. Here’s a copy of it.

Hi. I try to fix my linux problems by myself but this one got me puzzled. I use Manjaro Compiz Standalone with Cairo Dock (MCCD) as my daily driver and I have been using that setup for at least two years without any compiz related problems till I updated my system yesterday. I built the MCCD desktop from Manjaro XFCE and that’s why I post my request here (from the XFCE desktop.)
In short after the update yesterday I shut the comp down to do something else and later started up to find that I got nothing but a black screen and a cursor when login into MCCP. I restarted and was able to log into the XFCE desktop however compiz dit not funtion and the CCSM wouldn’t start. I used the feedback I got from the terminal, and found out I needed to reinstall compiz-easy-patch from the AUR.
Reinstall didn’t work so I uninstalled it. However when I try to reinstall it I get:

:: Parsing SRCINFO (1/1): compiz-easy-patch
failed to parse compiz-easy-patch: Line 84: key “pkgbase” can not occur after pkgbase or pkgname: pkgbase = compiz-easy-patch

And then it quits and goes back to the promt.
I have tried to install the compiz 9 package. That worked but it crashes all the time. Is there anybody who can tell me what exactly this means and how I can fix it please?

There is an AUR package already: AUR (en) - compiz-easy-patch

pamac build compiz-easy-patch

1 Like

Hi @MushroomMike, so basically there are 2 problems here. Sense there aren’t enough people who want to use compiz they have decided to no longer allow us to maintain the package in manjaro repos.

As far as specifics, the guy who was maintaining the package decided to quit working on it and recommended it be removed from the manjaro repos, so they complied even though we have told them we are willing to keep maintaining the package!

What this means for us is that we will now have to take 20 minutes to manually build the compiz package from the AUR on our own every time there is an update. Also we will individually have to keep track of any changes and make sure everything is compatible with the changes made to manjaro.

So the main issue with why compiz stopped working for you when you updated is because it’s no longer in the manjaro repos and the only solution is to install compiz-easy-patch or one of the other compiz options from the AUR. You could also install from source if you want.

This leads to the second problem, As far as I can tell there was a bug with compiz upstream. Seems to have something to do with plugins/opengl/src/vertexbuffer.cpp:167 according to a bug report on Launchpad. This appears to be affecting certain things such as expo and anything that uses deformation, so for that we will just have to wait until they fix it.

Another thing I had to do when all this happened is completely remove the compiz-easy-patch in Pacman because it had changed from a manjaro repo to AUR with the same name :roll_eyes:. Then I had to remove all the compiz settings in ~/.config. Then re-installed compiz-easy-patch from AUR.

Personally I will probably be leaving manjaro because of this. I’ve been using manjaro for over 5 years and they have been good to me until now, but whenever someone sells out for profit it’s never too long before they start screwing over the people that use their software. Mark my words, this is just the beginning. Hell, I wouldn’t be surprised if they delete this post.

1 Like

For example, what about maintaining gtk3-classic? Manjaro wasn’t company then. So what will be the argument? M-Team is lazy, and they drop it to have more time for slacking?

Frede didn’t stop maintaining the package because he felt bored. It seems that there was no one, with spare time to maintaining package, so what is strange in it? It’s not the first and last time.

I am aging considerably faster than I anticipated - my health are deteriorating - so I cannot keep up with a stable maintenance of the following community ISO

This is just a BS, mark my words. You didn’t get what you want, and now you’ll act like an eight-year-old in a store with toys?

I’m using Compiz on all of my machines (Manjaro and Arch) and I agree that Compiz has been a problematic package in the past, it happened quite some times that protobuf has been updated requiring a rebuild of the Compiz package, but the rebuild has been forgotten and slipped through the testing process. Since I am sitting on stable, it’s not up to me to blame anyone though. :wink:

Question is, how to have Compiz integrated in a way that doesn’t require the users to build the package on their machines as the compilation process is quite time intensive, and also it is then up to the user to check for possible protobuf updates and rebuild the Compiz package by hand. I take it, the proposal is to have an additional repo providing a Compiz binary package? Would be great to have this or any other solution!

1 Like

First of all, I Never said anything about anybody being bored, so don’t put words in my mouth, I was thankful for his work and for the work of the maintainers before him for keeping it alive for so long. Also, there is someone who is willing to take over, but we never had a chance, the decision was already made.

Again, those are your words, not mine. The people from manjaro have never been lazy, that’s why I liked manjaro so much, the problem imo is they need money now and aren’t willing to spend the time for things like this.


At the end of the day I’m not going to argue with you about reason, the fact remains that manjaro decided to take away a valuable resource without giving the community the opportunity to continue offering the package. There are people willing to support it, there are people actively using it, and there has been no meaningful reason given as to why it cannot continue in the repos.

The community will always find a way, that’s what we do!

I have been using Manjaro Compiz (easypatch)/Cairo Dock since the first day I’ve been using manjaro. It is sad to hear that is has been taken out of the repos.
The AUR compiz easy-path package does not build anymore, I’ve commented that in the AUR.
I certainly hope, that manjaro will not degrade further, obviously due to monetary reasons.
So are there any suggestions to get a running compiz that does compile (and not crash if it compiles, as the other compiz package) ?

I just built it on one of my machines successfully. Is there anything possibly related to the error above the line which you posted in the AUR comment?

For me I had to manually remove everything compiz related. I did that by removing compiz-easy-patch in pacman. Then I rebooted using xfwm. Deleted all compiz related config files in ~/.config rebooting again and from there i install pacman -S metacity then yay compiz-easy-patch from AUR.

For me it built successfully by just removing compiz-easy-patch and then building it again (both via pamac).

I’ve removed compiz easy patch and installed the latest git version. Seems to work.

@Photon ,I don’t know. The text I’ve pasted was taken from the output of the build processs. (I did not remove anything at that point)). It happened after I updated manajoro today. After reboot compiz didn’t work anymore…

The build was not successful so it is not surprising that Compiz didn’t work after a reboot, I was just wondering if there was some output during the build process which helpt to understand what failed.

Not really. One patch seemed not to have worked, after that compilation progress to 4% - then this meager line. Nothing else.

I think, this is quite relevant information for the package maintainer to fix the build problem. :slight_smile:

1 Like

Yes, you are right. Obviously I was too baffled to see broken code in the vicinity of manjaro :wink: I’ll try to reproduce it.

1 Like