¿Como puedo hacer para poder escribir una tilde?


#1

Me resulta imposible escribir tildes en el portatil. Esto no parece ser una cosa ´unica a algunas aplicaciones, pues ni siquiera en LibreOffice me pasa. Si alguien sabe como arreglarlo, le estar´ia agradecido



EDIT: Vale, resumen del problema
Tenia mi teclado en Español, pero en la variante “nodeadkeys”. Cambie la variante desde la terminal con los comandos que sugirió torvic, pero no funciono, aún después de un reinicio. También lo intenté con Manjaro Settings (En español era algo como Gestor de Configuración de Manjaro o parecido), pero también fallo.

El truco era usar los ajustes del propio GNOME. Me di cuenta siguiedo la guia que linkeo XtyM en el post #22, y una vez lo hice, el arreglo fue instantáneo, no necesité reiniciar.

Si alguien tiene un problema parecido, aunque no creo porque lo mio fue un problema muy específico, así sería como se arregla. Espero que a esa hipotética persona le haya servido.

Gracias a torvic y XtyM


#2

Qué dice localectl status? Tus acentos agudos no están bien tampoco…


#3
[ayhon@bower ~]$ localectl status
   System Locale: LANG=en_US.UTF-8
                  LC_NUMERIC=es_ES.UTF-8
                  LC_TIME=es_ES.UTF-8
                  LC_MONETARY=es_ES.UTF-8
                  LC_PAPER=es_ES.UTF-8
                  LC_NAME=es_ES.UTF-8
                  LC_ADDRESS=es_ES.UTF-8
                  LC_TELEPHONE=es_ES.UTF-8
                  LC_MEASUREMENT=es_ES.UTF-8
                  LC_IDENTIFICATION=es_ES.UTF-8
       VC Keymap: es
      X11 Layout: es
       X11 Model: pc105
     X11 Variant: nodeadkeys

Esto es lo que sale. ¿Podr´ia ser el nodeadkeys?


#4

Sí, puede ser.
No tengo teclado español, pero puedo bien usar tildes y acentos, eso sin “nodeadkeys”.


#5

¿Como lo cambio? ¿Alguna idea?


#6

Hmm…quizás localectl set-x11-keymap es


#7

No ha cambiado nada

De todas maneras, voy a reiniciar, y ahora vemos si sigue asi o funciona el cambio


#8

Tienes que reiniciar el ordenador.
Qué dice localectl status después de la modificación?


#9

Vale, sigo sin poder poner tildes (geograf´ia) pero localectl status ha cambiado

[ayhon@bower ~]$ localectl status
   System Locale: LANG=en_US.UTF-8
                  LC_NUMERIC=es_ES.UTF-8
                  LC_TIME=es_ES.UTF-8
                  LC_MONETARY=es_ES.UTF-8
                  LC_PAPER=es_ES.UTF-8
                  LC_NAME=es_ES.UTF-8
                  LC_ADDRESS=es_ES.UTF-8
                  LC_TELEPHONE=es_ES.UTF-8
                  LC_MEASUREMENT=es_ES.UTF-8
                  LC_IDENTIFICATION=es_ES.UTF-8
       VC Keymap: es
      X11 Layout: es

#10

Y en KDE, todo está bien reglado? Puedes cambiar el layout del teclado en KDE “Settings”.

No tengo otro idea, pero puedes ver todas las opciones disponibles con

localectl list-x11-keymap-layouts
localectl list-x11-keymap-variants
localectl list-x11-keymap-models

Y puedes activar una combinación de layout,variant,model con
localectl set-x11-keymap <layout> <model> <variant>

Ejemplo: localectl set-x11-keymap es pc105 sundeadkeys


#11

Aaah, se me ha olvidado actualizar mi perfil. Ahora mismo estoy en GNOME, me cambie hace poco, si los ajustes que decias son unicos de KDE, entonces normal que no me salga.


#12

No, esos ajustes son para todo el sistema X11.
Sin teclado español no puedo probar…


#13

Hmm, parece complicado… ¿Tienes alguna idea de donde mereceria la pena investigar? Ya he buscado X11 variant en internet, y todo parece ser demasiado tecnico para mi.


#14

Puedes ver en /etc/X11/xorg.conf.d si hay alguna otra configuración del teclado.

En mi muy vieja instalación, hay esto para mi teclado CH:

Section "InputClass"
 Identifier "system-keyboard"
 MatchIsKeyboard "on"
 Option "XkbLayout" "ch"
 Option "XkbModel" "pc105"
 Option "XkbVariant" ","
 Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle"
EndSection

#15
[ayhon@bower xorg.conf.d]$ ls
00-keyboard.conf  90-mhwd.conf

Tengo dos configuraciones, supongo que 00-keyboa* es la que nos interesa. Voy a probar a copiar y pegar lo que tu tienes en la mia. Y antes hare una copia del archivo, por si las moscas


#16

Vale, he intentado reemplazar ambos archivos .conf y no ha cambiado nada.


#17

Creo que tu problema es este :slight_smile:
[ayhon@bower ~]$ localectl status
System Locale: LANG=en_US.UTF-8

Cambia el lenguaje local del equipo a español lo tienes en inglés americano. Esto lo puedes hacer en las ajustes de idioma de tu entorno de escritorio.


#18

¿Tendria que cambiar el lenguaje de mi ordenador? La verdad es que prefiero dejarlo en ingles, la mayoria de tutoriales o guias en internet estan en ingles y es mas facil seguir los tutoriales si el ordenador de la guia y mi ordenador tienen el mismo nombre en las distintas opciones. Voy a comprobar si se arregla asi, pero no estoy seguro de que deje el ordenador en Español.

¿No habria entonces ninguna forma de escribir las tildes desde un teclado en español a un sistema en ingles?


#19

He cambiado el idioma del ordenador a Español, y sigo sin poder escribir tildes. Pero eso no es lo mejor. Lo mejor es que he reiniciado dos veces mi ordenador, y aunque en la primera vez se cambio el nombre de las cosas al español, la segunda vez volvieron al ingles. Y la segunda vez, tenia puesto que todo mi sistema estuviera en español. ¡Curioso!


#20

Es muy raro :wink: si encuentro algo te digo