Comments [root tip] NordVPN on Manjaro

I do not use nordvpn-bin, but I am using openvpn of NordVPN.
There is the list of OpenVPN: OpenVPN configuration files | NordVPN It is pretty more stable than nordvpn-bin, but no need automatically select IP on connection. :wink:


Please do not read my post that is not about “How to setup NordVPN”
My old comment/post has been split from the main thread [root tip] [How To] NordVPN on Manjaro

The stability of NordVPN was not in question in fact it works very well.

It was more like a troubleshooting issue as I know other members use NordVPN and would benefit from knowing why the resolv.conf is not reset on a default Manjaro installation.


Thanks for this. At first I think this is something NordVPN should fix, but the fix never comes, so I guess it must be something else, but I have no idea what.

I disagree. I completely understand the NordVPN developers.

Arch and Manjaro is not officially supported by NordVPN - and as a developer and Manjaro maintainer I can accept that.

The reason Arch based distribution are not supported is due to the multitude configuration where you build the system from scratch and NordVPN cannot support endless configurations.

For some reason - and that is before my time - Manjaro decided to use openresolv as the resolver.

You could argue that the issue is due to the Manjaro choice to use openresolv - which seems a little off when you think of Manjaro using systemd for everything else.


I think Manjaro will change systemd-resolve to be standard, like standard package/lib in Debian and Ubuntu, they are more supported than other non-deb distros.

I got the error after switching from openresolv to systemd-resolvconf.

The output of journalctl -b -p 3 :

Dez 03 16:52:24 zesko avahi-daemon[342]: chroot.c: open() failed: No such file or directory

It is affected in KDE Xorg, but GNOME wayland has no issue. Both use and enable avahi too.

  • If I disabled avahi-daemon.service in KDE, the issue is gone after reboot.
  • If I switched back to openresolv, then the issue is gone after reboot.

It seems, avahi and systemd-resolvconf are in the conflict, but avahi need use openresolv, right?

From the list of the dependencies - no - avahi doesn’t use openresolv.

I don’t use avahi - while it appears to be the dependency of several packages on my system - I have never experienced issues when not having the services and socket enabled.

1 Like

Once every few hours, NordVPN completely blocks all internet traffic (even direct IP traffic is blocked, e.g. ping It seems to lose connection to the VPN server it was connected to, but is unable to establish a new connection. This has been an issue for longer, but the fix was to just restart the nordvpnd.service. This no longer works. I have found a workaround which I posted here:

Has anyone else experienced this issue? Is it also caused by this same DNS failure or is it something else?

(Is this the right place to post this?)

You are right about the iptables rule directing traffic into the VPN tunnel.

This rule ensures that your dns doesn’t leak.

I know that some has experienced connection drops - but I have not.

I think it is somehow related to the DNS the default dns resolver used on Manjaro.

Have you tried switching to systemd-resolved?

1 Like

@linux-aarhus nordvpn recently changed their login method to now only login via nordaccount ie web browser.

when typing “nordvpn login” in the cli you are now directed to a web page which, once logged in, is suppose to call the app back and log you in. Exactly how they intended to do that I dont know but I could not get it to work, ie clicking on the link and then choosing xdg-open started the app but had no effect.

The only solution was to copy the link, that is provided after the successfull login on the web, and then run: nordvpn login --callback “PASTE LINK HERE”.

Might be worthwhile adding this solution to your original post that has been incredibly helpfull already

Have a look at

By following the original post that this comments thread relates to (i.e. switching to systemd-resolved) and installing wireguard-tools (only necessary if you are using nordlynx) it seems to have been resolved for most.

1 Like

Another workaround mentioned for login issue was to try:

nordvpn login --legacy
1 Like

the nordvpn.desktop file contains this command

nordvpn login --callback %u

I just played around with the new login.

The nordvpn login command - run in terminal - generates an url - which you have to open - then login - and allow the webpage to do a callback to the nordvpn app. If you do not allow this callback you will not be logged in.


Had not tried wireguard-tools yet. Will also switch to systemd-resolved, would be awesome to just have NordVPN working. Thanks for the help, also thank you @linux-aarhus.

Update: it seems to work. I added this solution to the Arch Wiki (my first contribution there) to help others that don’t use Manjaro that are also experiencing this issue.