Commentaries about Manjaro 17.1 XFCE RC

Hello,
Sorry if I didn’t post in the right section, but I didn’t find a better place to talk about the release candidate. I’ve tested the new RC for Manjaro 17.1 XFCE in a virtual machine and I’ve noticed some problems.

1- The login screen doesn’t look right for me. The hostname (imaginaire) is just in a random place and there’s no button to shutdown or restart the computer while on it, which is something that’s just convenient to have.

2- The Desktop Settings is just completely broken. It’s impossible to do any changes in these settings because this window doesn’t respond to any command and therefore, I can’t do any customization. Also, when I open this window from the application menu or the pop-up menu on the desktop, this window is just hard to kill.


I also have this problem on Manjaro 17.0.6.

Also, I think manjaro-printer could be added. I mean, CUPS is already installed, it wouldn’t cost a lot to add a better printer support. Is there a technical reason why it isn’t here?

2 Likes

Comments about the XFCE 17.1 RC2

I tested the RC2 again in a VM. The login screen is still looking off, but at the very least, the Desktop settings isn’t broken anymore.

I’ve noticed it also on my installed system. Somehow lightdm has not the option to shutdown. Maybe a change in the login-theme is needed.

Edit: fixed by adding the indicators:

indicators = ~host;~spacer;~clock;~spacer;~language;~session;~a11y;~power

Login screen
It’s a bit basic and I think it needs some improvement, like moving the button to change the Desktop Environment near the little login screen, It’s at the bottom right, no one looks there. People focus their attention on the center of the screen at the login page, everything should be there in my opinion, I mean, 100% of the options, forget screen corners, just put everything inside the login window or near it.


Xfce
I’m using Stable but after updating to latest Xfce packages I had some issues, check this thread later. Desktop Settings was freezing here too, I think it has something to do with the compositor and bugs with Xfce packages, after disabling the compositor the problem was solved. But apparently they fixed this issue, is back to normal here on the new version(xfdesktop-gtk3 4.13.1-8 I think).

Also, my windows were flashing/flickering as I was moving the cursor and removing xf86-video-intel solved the issue. My panel(xfce-panel-gtk3 4.13.2-1) was still weird though, I had to go back to the old one, xfce-panel 4.12.2-1.

Some of the latest Xfce packages have some bugs, if something is broken just remove it and install an older version, this is what I did to fix things after updating some Xfce packages manually.

I think it is a long standing bug in xfdesktop. The user is just supposed to wait when they open the window. It becomes responsive after the image date gets processed.