Colors does not apply for all on KDE


right click2

So, here is the thing, for some reason, after an update earlier not the plasma 6 update but before that, the add/update software colors changed and no matter what I did they stay the same, also in vivaldi if I right click when I am logged on with my user it shows (pic 1) however if I open a gues user the right click applies the correct colors that I have (pic 2), something to do with user data or cache maybe?
I don’t know, not an issue affecting performance at all, but I needed to know if there is a fix to it as it just bothers me.

1 and 2 look like different areas of browsers.

Besides the fact that the major browsers are GTK … they usually have their own styles, especially for their own ‘utilities’.

3 is one of the pamacs.

Pamac is also a GTK application. And a libadwaita one as well if its the gtk4 variant.

So now the quoting;

While there are also ways to handle gtk4 applications, to some extent.
What you are referring to as the ‘change’ is likely the new pamac.
You can get the older gtk3 one that is easier to theme by installing pamac-gtk3.

I dont know how you have attempted to style your browser or what you expect it to look like.

1 Like

3 is definitely the newer GTK pamac, I switched back as I mostly use desaturated greys with hints.

But yes, the premise is correct - this isn’t a Manjaro bug.

Most apps do look fine, but it’s kinda worrying that GTK keeps most people happy by dumbing down theming to simply ‘light mode or dark mode’.

Firefox looks fine to me with defaults - with the plasma setting for ‘GTK theme’ on the default (Breeze) so that it accepts the colourscheme.

I’m not sure if Global themes can affect this setting.

You need to have the same theme scheme for both Plasma/Application style and Gnome/GTK style too, also make sure to have the same theme for Kvantum.

I was showing an example but even if it’s both areas it’s the same thing, in addition, it’s a guest profile, so the same browser, but I chose to open another profile on it.

Oh, then probably an update to the GTK is what made this issue, it’s not really a performance issue, but I wanted to inquire about it. Do you happen to know how can I make all the GTK applications apply the styling?

How can I do that?

You will have find a theme which matches - install it and apply it using the Applicaton Style option in Plasma Settings.

The page has an option in the upper right corner labelled Configure GNOME/GTK …

Will try that thanks