Clpeak error for 5600XT -- Build Log: fatal error: cannot open file '/usr/share/clc/gfx1010-amdgcn-mesa-mesa3d.bc'

SOLVED – a reboot fixed it. The error still appears but xmrig is happy now.

Hello all!

I have fresh install of manjaro version 21.2.5.

Kernel is upgraded to 5.17.0-1-MANJARO.

My goal is to have xmrig correctly running with the 5600 XT GPU that I have.

I believe that if “clpeak” shows the card working properly, then xmrig will be able to use the card.

Currently clpeak shows an error for this card:

Platform: Clover
Device: AMD Radeon RX 5600 XT (NAVI10, DRM 3.44.0, 5.17.0-1-MANJARO, LLVM 13.0.1)
Driver version : 21.3.7 (Linux x64)
Compute units : 36
Clock frequency : 1650 MHz
Build Log: fatal error: cannot open file ‘/usr/share/clc/gfx1010-amdgcn-mesa-mesa3d.bc’: No such file or directory

Sure enough, the file doesn’t exist.

Following other info available online, I ran yay -S opencl-amd but that hasn’t helped.

Can anyone offer advice about the next steps to get the 5600XT working with clpeak?