Clonezilla cannot clone my manjaro drive

clonezilla
partitions

#5

@LinuxLoverForever saddly timeshift will not cover all my needs.

@fhdk as @Citroen said i use an external usb stick, the same i always used with the same version of clonezilla, and i have used it to make about 15 clones so far, of many drives and OSes.
(and these are high-end devices)

my clonezilla usb can clone anything, except manjaro or any manjaro flavor… whats up with that ?

my drive is not encrypted, or has any crazy setup.

the problems started after i used manjaro, manjaro deepin and any other distro after that. i have reverted back to windows 10, scaned my drive, wiped it clean and made a fresh install of manjaro kde, and i still cannot clone it…


#6

I cannot explain that because there should be no problems.

I am using Clonezilla to image the bladebook system when I have installed an OEM version.

So I have cloned every different Manjaro version I have shipped on a Bladebook which makes me say there must be something else going on.

An I sometimes have cloned it several times due to my perfectionistic approach to the systems.


#7

that is what is bothering me too, i used this clonezilla usb stick to clone another machine that had dual-boot, just last week…
but not manjaro. EVER

i guess i will try a new clonezilla download on a different usb, and save the disk to a different external HDD, and see what happens.


#8

It does sounds like there is a new problem with your media since it carries over to other distros. Trying a new Clonezilla usb stick is probably a good start in troubleshooting the problem.


#9

Clonezilla on a new usb - that might do it.

I don’t think partition layout make a difference - the only thing that set me apart from you is maybe LVM.

Clonezilla is an app with may years of service and I can’t imagine anyone not cloned a LVM structure.

Manjaro does not create or maintain any odd structures of any kind, so there is only the thing you can do yourself.

Do you use encryption of any kind?

If clonezilla is not doing a bitwise clone but reads the files and compresses them - that could be a answer if the file is locked - you did mention some group access errors, and those groups does net exist on default Manjaro system.

Is your disk faulty?

I searched using google for clonezilla errors 127 101 and though this might be a too broad result with unrelated results - one of the results made me think the above question.

Doing a slightly different search came up with - among others - this result


#10

Out of my own personal curiosity what needs are you referring to?


#11

Speaking for my self Timeshift does not provide disaster recovery i.e. booting on bare metal. It provides functionality similar to Windows System Restore, but it does not provide the same level of protection as an imaged drive that can be installed on bare metal.


#12

You mean you can’t recover if the drive fails? This is exactly why I use to ask about backing up the snapshots it makes and learned that it’s possible if you zip it in a tar or (and more preferably) format the backup drive to ext4.


#13

Nope. You would have to reinstall, then move the timeshift files over or do it all in a chroot. Or you can simplify the whole process and Clonezilla disk or usb and a file sharing protocol supported by Clonezilla to transfer the image directly to your drive, or an external drive with your images. When it is done, boot into your exact copy. I use Clonezilla for imaging, Timeshift as a quick system restore, and Dejadup/Backups for incremental backups of my /home.


#14

Oh I didn’t know this was possible in general as I can’t imagine how you would extract the whole imagine on to the new drive.


#15

Clonezilla walks you through it. You have options to connect via smaba for instance or to choose a source drive and whihc drive to copy it to. After it performs the operation, you have a working install. You can also setup a Clonezilla Server and install to up to 40 boxes at the same time. It is actually multiple tools in one, Partclone, Partimage, ntfsclone, and dd.


#16

Nice I can see that that being VERY handy for old windows machines because of the windows key authenticain being bypassed. I imagine it is or was or still is a very popular program in the business world for windows machines because now I can see why. :slight_smile: Not to mention it’s an easier restore process for IT people.


#17

@LinuxLoverForever i just like having my customized distros fully saved.
and sometimes i need my windows 10 up and running in 15 minutes tops.
then back to my linux OS with all my settings and users in 15 minutes, no reinstalls.

i have many clones from many computers, of windows systems (with licences), linux, bsd, i even have a clone of my clonezilla usb drive :rofl:

@nadb i know all to well about windows system restore, it will overwrite files and create issues.
would not recomend


#18

update

i have downloaded a new version of Clonezilla, 64 bit this time, and installed it on a new usb stick, and managed to clone my SSD to a different external HDD then i used before.
all went well

oddly enough i tried my old usb with the old Clonezilla (32 bit version) and that worked too. :confused::man_facepalming:

@fhdk
the drive is ok and not encrypted
those errors could also indicate that i did not have enough free space on the HDD, but 45 GB is enough to clone a 32GB and i did it before, with other OSes…
i will free up some space and try again with the new clonezilla on the old HDD.
:thinking:


#19

I had already prepared something :wink:
The @klaude_kraap Cup (avatar :wink: )

Is it solved by post #18?
Then

m-i-s-100 :slight_smile:


#20

timeshift wont create partitions for you but you can restore a backup to fresh partitions without needing to re-install first. i had to do like this to “clone” my manjaro install to a new ssd, clonezilla would not work and neither would dd because the new drive was 250gb and the old was 256gb.

clonezilla certainly would have been easier had it worked, but if the new drive is smaller than the old drive, it wont work regardless of how much data is on it.

boot live usb > create partitions > restore timeshift backup to new partition/s


#21

It is still possible if the amount of data stored in the old drive is smaller than the new drive by selecting the -icds option in advanced parameters. Have a look at this link.


#22


:wink:


#23

ok so here it is, the problem is not my SSD or the HDD, its just the old clonezilla version, which was 32bit.

so i have installed the newer 64bit clonezilla and i could clone anything this time, including manjaro, using my regular external HDD to save the clone. with no errors

for who might be interested, the old clonezilla version was 2.4.5-23-i686 and the new one is 2.6.0-37-amd64.
and a manjaro saved disk has about 4,2GB(compressed), with not much software installed and 4 users.

in the future i will use both of them, in case i cannot restore my old clones made with the 32bit version.

:triumph:


closed #24

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.