Clockify-desktop failing to update


Im trying to update my clockify-desktop and it keeps failing (seemingly with checksum). Any ideas how to fix this?

Synchronizing package databases...
Warning: package-query: local (1.11-1) is newer than community (1.10-1)
Warning: trizen: local (1:1.60-1) is newer than community (1.64-1)
Resolving dependencies...
Checking inter-conflicts...

Building clockify-desktop...
==> Making package: clockify-desktop 1.8.69-1 (Sunday, 04 April, 2021 04:17:17 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Clockify_Setup.deb
==> Validating source files with sha512sums...
    Clockify_Setup.deb ... FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build clockify-desktop



Have you tried what is suggested in the comments on the package page ?

Thanks!! that worked! :slight_smile: Checking out the package’s AUR comments is now part of my to-check list next time this happens.thanks! :slight_smile:

For those who will have the same issue. Here’s what i did

  1. I checked the build file
  2. I looked for the URL of the deb file it was downloading
  3. Manually downloaded it and did sha512sum <filepath>
  4. Copied the sha512sum and pasted that into the build file where it was defined
  5. Re-run the update

viola! :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.