Clock keeps resetting to 24-hour vs. 12-hour

deepin

#1

Every time I reboot the clock in my dock/tray resets back to 24-hour. How do I get it to stay in 12-hour mode?


#2

#3

I did a few searches inside the forum here, as it seemed to be a problem specific to DeepinDE. I did not do the specific search you mentioned, although first glance tells me it wouldn’t have helped.

I can’t speak for everyone, but I probably average around 100 Google searches a day, maybe more.

Speaking of not useful, the two results mentioned do not address my issue. I have no problem changing the time to 12-hour format, but it resets to 24-hour format on every reboot.

But hey, guess I’ll just move this issue to Google and figure it out myself.


#4

And why do you address me something that was said by somebody else?
If it happened that i read about deepin and 12 vs 24 hour clock some time ago, and is not useful for you, you can move along.
The gsettings set com.deepin.dde.datetime is-24hour false would prevent the very thing is happening on your install, but probably depends if you run it as user or as superuser.

I can’t speak for everyone but i have 210 solved issues on this forum, but i don’t expect to have all my interventions as solutions, nor to be regarded to such high personal expectations from OP.


#5

@bogdancovaciu I edited my post but you didn’t see that before you responded. It took me a few minutes to realize that you were just linking to another post.


#6

Bogdan - I ran the gsettings command as me and rebooted but it didn’t resolve the issue. I ran it as sudo but it threw an error.

The resolution appears to be this: In the dock, when you right-click the clock, select Time Settings. Then select Time Settings in the side panel. The time displayed will be in 24-hour format, always. Ignore that. Make sure it is the correct time, then click CONFIRM. You will be prompted for the Admin password. This saves any changes.

If you right-click on the clock in the dock and select ‘12-hour Time’ it will adjust the clock to the appropriate time and add either AM or PM. If you don’t see AM or PM it is displaying in 24-hour Time. That’s the part I was missing.


#7

I’m doing an install right now as Deepin was not in my installed DE list. On live media i can set the time to 12 hours by right click, but opening the dconf editor seems to keep the 24 hours format.

image

That is real sign that if i log out or reboot will be defaulted to 24 hours.
BRB once is installed. 2 minutes top.

Edit:
The settings survived the reboot
image

I will make the updates and see if there is some bug that was introduced, or we have too look at some permissions in the home folder + if making use of dconf editor if something changes.

Edit2:
in ~/.config/deepin/dde-dock-datetime.conf it seems i have it to:

[General]
24HourFormat=false

and this are the permissions, remained so also after update
image


#8

Just throwing it out there, I have this issue as well. I want to use 12 hr time format, but after a reboot it always defaults to 24 hr time format.