Clicking sound at random intervalls


Since a few days ago I noticed that my speaker starts to make some strange clicking noises at random intervals while playing audio. I tried jack and bluetooth too and the problem remains. seemingly it starts at random not just when I start playing audio but while I’m playing audio and it stops if I pause playing but after a while (few seconds) it starts again. I’m using pipewire. Sorry if my explanation is too vague I’ve never had any audio issues yet since I’m using Linux for 3 years now. I don’t know where to collect information or logs or anything and I’d be grateful if someone could point me in the right direction.
I even tried downgrading the kernel from 6.1 to 5.15 but it didn’t help.

Some system info from inxy -Fazy:

  Kernel: 5.15.89-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=0ed1ad32-d1a3-4a13-b622-68a1cbbd24bb rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: LENOVO product: 81Q9 v: Lenovo Yoga C940-14IIL
    serial: <superuser required> Chassis: type: 31 v: Lenovo Yoga C940-14IIL
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: AUCN54WW date: 01/09/2020
  ID-1: BAT1 charge: 10.5 Wh (26.8%) condition: 39.2/60.0 Wh (65.4%) volts: 7.2
    min: 7.7 model: Celxpert BASE-BAT type: Li-poly serial: <filter>
    status: discharging
  Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xB6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 1010 high: 1172 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1003 2: 791 3: 1172
    4: 1058 5: 1056 6: 1063 7: 1036 8: 906 bogomips: 23968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
    empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0 chip-ID: 8086:8a52 class-ID: 0300
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-1:2 chip-ID: 13d3:56b2 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: X: loaded: intel gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: LG Display 0x061f built: 2018 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: Mesa Intel Iris Plus Graphics
    (ICL GT2) direct render: Yes
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-icl
    alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0401
  Sound API: ALSA v: k5.15.89-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: down mac: <filter>
  IF-ID-1: br-c4a1f1e79773 state: down mac: <filter>
  IF-ID-2: br-f6ae8792e07c state: down mac: <filter>
  IF-ID-3: docker0 state: down mac: <filter>
  IF-ID-4: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:4
    chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 409.28 GiB (85.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFS512GD9TNG-L3A0B size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 80050C10 temp: 42.9 C scheme: GPT
  ID-1: / raw-size: 103.21 GiB size: 101.03 GiB (97.89%)
    used: 48.81 GiB (48.3%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 28.8 MiB (11.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 133.79 GiB size: 130.63 GiB (97.64%)
    used: 108.43 GiB (83.0%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  Alert: No swap data was found.
  System Temperatures: cpu: 57.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 321 Uptime: 1h 2m wakeups: 3018 Memory: 15.19 GiB
  used: 3.84 GiB (25.3%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1802
  pm: pacman pkgs: 1701 libs: 442 tools: gnome-software,pamac,yay pm: appimage
  pkgs: 0 pm: flatpak pkgs: 101 Shell: Zsh v: 5.9 running-in: tilix
  inxi: 3.3.24

Forgive me if it’s a dumb question but could it be interference of some kind, coming from outside of your machine? Also, do you only hear it on the speaker when you are playing something, or also when it is paused/not playing?

It seems odd that it has just started recently. Hopefully you find a solution soon.

Ruziel :slight_smile:

Have a look at this tutorial: