Clean Install Problem


Hi, my name is Max and I am having some issues installing version 18.1.3 with Kde Plasma.

First my specs:

Asus Crosshair VIII Hero MB
AMD Ryzen 9 3900
NVidia GeForce RTX 2080 Super
32 MB RAM

This is a brand new build.

Second, I was able to install Pop OS with no issues. I just have my heart set on Manjaro.

Third, I'm installing off of a USB drive.

Hopefully, that's all the necessary details.

The issue:

When I get to the install screen, first I tried installing with the free driver selection and I got dots on my screen instead of a readable text. After searching the forum, I then tried the nonfree driver and it went through the process until TLP. It hung. So again after searching the forum, I hit Ctrl+Alt+F2 and got a login screen. The problem is that I have not set up a user therefore I am stuck. Also, the uname and pwd for the live cd are there however, I'm not sure how that helps me.

Your assistance is appreciated.

default username in live boot is
manjaro
and password is manjaro

1 Like

I did this, however I still get no desktop.

I have run the "sudo pacman-mirrors -f3" and "sudo pacman -Syyu" commands and it seems like there are a lot of updates that are downloaded. However, when I reboot, it goes back to the install screen and does not seem to have the updates.

I have been searching through the forum and reading every post I find regarding the black screens or no desktop and the TLP hanging issue. I just want to remind everyone that this is a clean install. There is no OS on this system. I also know that I can install from a live CD. However, I'm only getting to a command prompt, not a desktop where I can work through the issue.

Thanks for your patience.

This will help you NOT, is live media, aka volatile.
Please use a different ISO version, for instance:

Disable any Fast Boot and Secure Boot in BIOS. Make sure the SATA controller is set to AHCI. Use nonfree driver option.

I made sure to do this before posting as every post I read said so.

I am downloading the updated ISO now and will update the post later.

Thanks for your help. Its much appreciated.

I ran the updated version and I'm still hanging at the TLP startup. Where do I go from here? I know that Ctrl+Alt+F2 will get me to a prompt but, since this is a live iso, what can I do to move forward?

I went into grub edit and removed the quiet cmd and I am seeing acpi errors.

Well, that is a starting point to identify the issue. What errors?

Is there a log that I can look at? My camera only catches part of it.

With journalctl -b from TTY you should see some things. Quoting from another post that suggests this i forgot about:

after looking through the journalctl log, there are only 2 errors.

ACPI error and KVM disabled (which I'm assuming that it's not an error)

That ACPI BIOS Error: AE_AML_PACKAGE_LIMIT only makes me think at the UEFI/BIOS that needs an update as that is what's giving the kernel wrong ACPI information.... but i might be wrong. Check the motherboard manufacturer site and see if there is new available BIOS, and try again to boot from live media and install.

That is not the issue for now AFAIK.

Do I add this to grub or as a startup argument?

Yes, Press E while in Boot Grub Menu on the Boot tab, then after adding it (you can replace the quiet with it) press F10 to save and continue booting.

Grub settings:

Ok, make it look like this

Then press F10

No change.

Should I replace "quiet" with: acpi_osi='Windows 2018' as suggested elsewhere along with your changes?

AFAIK those kernel boot parameters are for Laptops.

Forum kindly sponsored by