Cinnamon - launchers for terminal apps not working

cinnamon
#1

I am currently trying to build Cinnamon 18.0.3 ISOs and noticed that the launcher for manjaro-architect will not do anything while running the exec command from the terminal works fine.
I then tried the launcher for htop in /usr/share/applications. It also does nothing.
So looks like the terminal=true line in the launcher has some kind of a problem.
Ideas anyone?
@Ste74 @Chrysostomus @Thanos_Apostolou @linux-aarhus @philm

Manjaro-Cinnamon 18.0 released
#2

I have noted that anything Gnome based requires the locale to be set.

If locale is not set in locale.conf then terminal will not launch.

#3

Well the terminal does launch fine. Just the launcher files are not working … :thinking:
edit: locale is set anyway btw

#4

Nemo works here and so does the menu but the menu icon disappears still think its a panel problem as it seems random what works and doesn’t work for different setups.

#5

nemo? I am talking about the desktop launcher for manjaro-architect and the launcher for htop in /usr/share/applications …
But hey! manjaro-architect launched from the menu works just fine and so does htop! how’s that possible??

#6

So what is the difference between the launcher on the desktop and the launcher in /usr/share/applications

#7

I just tried this:
opened the menu and launched architect from there. works
deleted the desktop entry for architect and created a fresh one via menu right click > ‘Add to desktop’. Doesn’t work !
Very odd, indeed!

#8

Is Nemo used for the controlling the desktop in Cinnamon?

If so - it could be a regression in Nemo - but I have really no idea.

1 Like
#9
#10

Yes. Probably a nemo issue … For now I will just remove the architect entry on the new ISO. It can still be launched from the menu or terminal dirctly if needed.

#11

Workaround I found for now is calling gnome-terminal directly from the launcher
Exec=gnome-terminal -- sudo /usr/bin/setup
:sunglasses:

Manjaro-Cinnamon 18.0 released
closed #12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.