Cinnamon and Nemo issues in the last week or so

Hey, has anyone experienced any of these issues over the last few testing branch updates?

  1. After logging in, the desktop background stays black without loading an image for 30-40 seconds, and the systray and panel applets don’t load until the background image does, and the .xsession-errors log has this message LOG: [LookingGlass/info] Cinnamon took 630 ms to start followed by a gap of 30-40 seconds and then this:
cinnamon-session[1043]: WARNING: t+32.78984s: Application 'xapp-sn-watcher.desktop' failed to register before timeout
Flag 0x0001, status 0, EXIT 1 STAT 0
  1. gio trash in terminal and ‘Move to Trash’ in Nemo both now fail whenever I try to move a directory to Trash, even though moving a file always works?

Just noticed both these issues appear some time in the last 7 days, anyone else have either of these?

I tried making a new user, rebooting and logging in to the new user and both issues happened immediately, so I don’t think it’s anything to do with my .config files or anything. My /etc/environments file is also super minimal, I only have:

QT_QPA_PLATFORMTHEME=gtk2
GST_VAAPI_ALL_DRIVERS=1
VAAPI_MPEG4_ENABLED=true
GTK_USE_PORTAL=1

and I don’t think any of those variables would affect the issues I mentioned.

Only issuesI’ve had with cinnamon (on testing) sometimes changing kernel boots to black screen with no tty (booting in safe mode fixes it). And when trying to log out sometimes the desktop freezes and takes ages to log off. These don’t happen often and don’t think they’re related to your issue

1 Like

Thanks for that. I don’t think I’ve experienced either of those, I’ve actually had really good luck with multiple kernels and logging out, no issues there. I’ve googled these two symptoms and can’t see anyone else with either of them, so I feel like it’s something I’ve misconfigured, or it could be related to the large number of ‘icon theme’ type packages I have installed and removed in the last fortnight. Either way, if I can’t work out what’s going on I will file bugs against gio/Glib and also cinnamon/xapp and see if a solution can be found there, and I’ll update this thread in case anyone else experiences the same issues.

1 Like

Turns out the problem was I had set GTK_USE_PORTAL=1 in my /etc/environment to force some KDE-based programs to use native GTK file open and save dialogue boxes, but this had broken several other components throughout my system. Removing this variable solved it.

FYI… ! A better option for getting QT5 programs looking more like GTK based ones is to install Qt5 Configuration Tool.