Cifs: "mount error(20): Not a directory" while mounting


I have this kind of line in my /etc/fstab:

// /mnt/Folder cifs vers=1.0,credentials=/home/myname/.smbcredentials,uid=xxxx,gid=xxx,iocharset=utf8 0 0

While attempting mount -a, becomes an error:

mount error(20): Not a directory

and dmesg gives:

CIFS: Attempting to mount \\\Folder
CIFS: VFS: bogus file nlink value 0

What could be wrong, what to check, and what to try next?


does /mnt/Folder exist?

where is that directory, named “Folder”, under that IP?
is it at the top level?

and why is there two slashes in front?

check what you have

file /mnt/Folder

Is it yours or copied from a random guide?



// /mnt/Folder cifs vers=1.0,credentials=/home/myname/.smbcredentials,uid=xxxx,gid=xxx,iocharset=utf8 0 0

Do you actually own this - then everything is wrong - it actually lloks like a copy paste from a random guide on the interweb

Mount manually using mount command if you are unsure of the options needed

mkdir ~/temp
sudo mount -t cifs //ip.x.y.z/share temp

A very thorough troubleshooting guide

A from scratch

Is “Folder” the share name that points to the absolute path on the server?

SMB/CIFS is not like NFS. You don’t reference the absolute path on the server: only the share name

Each share is its own isolated “root directory” if it helps to think of it that way.

For example, the absolute path might be,

On the server you configured an SMB share with the share name “Videos” that points to /mytank/media/Videos on the server.

Your mount should reflect //

Not //

Also like @Nachlese and @linux-aarhus asked, does the directory /mnt/Folder even exist on your Manjaro client?

Don’t use fstab use systemd-mount units instead…
There is a tutorial by @linux-aarhus in the #contributions:tutorials section of the forum :wink:

It will make your life a lot easier and be able to fiddle around while booted up…

Sorry about delay, I had hurries, but better later than nothing…

Yes, there was “copy-paste-works”-type lines from year x. I’m not a specialist about this kind of topics.

Thanks about links! Mounting by using gvfs was the solution to my problem. :slightly_smiling_face:

Thanks about help for you, also! :slightly_smiling_face: