Chvt fails after starting second X

This seems consistent enough that it ought to be reported. i’m posting here for help with getting it reported it in a useful and effective way. This bug happens in ubuntu tho i was less successful pinning it down there, but here in manjaro it’s consistently repeatable, i’ve tried it on these manjaro ISO live systems:


and on my installed system i’ve tried it booting up with these kernels:


To invoke the bug simply

  1. boot up either the iso or the installed kernel
  2. ignore sddm and switch to ctl-alt-F2
  3. login
  4. switch to ctl-alt-F3 just to see that it works
  5. switch to sddm just to see that it works
  6. switch to ctl-alt-F2
  7. startx /bin/xterm #or konsole, qterminal, or i3-sensible-terminal
  8. switch to ctl-alt-F3 just to see that it works
  9. switch to ctl-alt-F2 just to see that it works
  10. switch to sddm just to see that it…doesn’t work!

On kde systems sddm is on ctl-alt-F7, on the others it’s on ctl-alt-F1.

And what’s the bug?

Trying to change back to the sddm VT doesn’t work!

Except that i just tried it on


and the bug doesn’t show up there. Well then, i’ll guess i’ll presume it’s fixed now, unless and until i run into it again on newer kernels.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.