Chromium vaapi: video turns black seconds after pause

Videos turn black a few seconds after pausing in Chromium when hardware decoding is enabled via --enable-accelerated-video-decode. The issue occured after updating to chromium 86 and still persists with 87 version. Google-chrome-canary have this problem too.
I am using h264fy extension because my videocard does not support vp9 hardware acceleration. There is no such problem in Firefox and hardware video decoding works fine there.

My system information:

System:    Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: CROSSHAIR VI HERO v: Rev 1.xx serial: <filter> UEFI: American Megatrends v: 6401 
           date: 12/07/2018 
CPU:       Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 81618 
           Speed: 3830 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 1: 3830 2: 3856 3: 3892 4: 3870 5: 3386 
           6: 3201 7: 2711 8: 3052 9: 2305 10: 2962 11: 3496 12: 3891 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 0b:00.0 
           Display: x11 server: X.Org 1.20.10 driver: amdgpu resolution: 1920x1200~60Hz 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.40.0 5.10.2-2-MANJARO LLVM 11.0.0) v: 4.6 Mesa 20.3.1 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Sapphire Limited driver: snd_hda_intel 
           v: kernel bus ID: 0b:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0d:00.3 
           Device-3: XMOS D30 type: USB driver: snd-usb-audio bus ID: 5-1:2 
           Device-4: C-Media Blue Snowball type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-2:3 
           Sound Server: ALSA v: k5.10.2-2-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel port: e000 bus ID: 05:00.0 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: TorGuard-NL1 state: unknown speed: N/A duplex: N/A mac: N/A 
Drives:    Local Storage: total: 953.87 GiB used: 714.54 GiB (74.9%) 
           ID-1: /dev/nvme0n1 vendor: Seagate model: XPG GAMMIX S11 Pro size: 953.87 GiB temp: 36.9 C 
Partition: ID-1: / size: 76.4 GiB used: 28.39 GiB (37.2%) fs: ext4 dev: /dev/nvme0n1p1 
           ID-2: /boot/efi size: 511 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p4 
           ID-3: /home size: 133.57 GiB used: 74.45 GiB (55.7%) fs: ext4 dev: /dev/dm-0 
           mapped: luks-616fd380-28e2-45c3-824b-506c5e68e26e 
Swap:      ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 34.0 C mobo: 25.0 C gpu: amdgpu temp: 44.0 C 
           Fan Speeds (RPM): cpu: 548 case-1: 661 case-2: 625 case-3: 0 gpu: amdgpu fan: 824 
           Power: 12v: 11.97 5v: N/A 3.3v: N/A vbat: 3.07 
Info:      Processes: 366 Uptime: 41m Memory: 15.63 GiB used: 4.76 GiB (30.5%) Init: systemd Compilers: gcc: 10.2.0 
           clang: 11.0.0 Packages: 1565 Shell: Zsh v: 5.8 inxi: 3.2.01 

Hi @Gafpdlas, and welcome!

I don’t give myself away as an expert and I might be completely wrong about this.

However, this seems to me that it’s either a problem with Chromium, in which case I would recommend a reinstall and a completely new profile, or it’s hardware, but seeing as it works in Firefox, I think it’s safe to rule out that possibility.

I hope this helps.

Tried with a new profile with chromium and google without extensions (except for h264fy) and the issue is still there.

Have you followed these instructions?

Yes. I followed these instructions and vaapi works fine. I have used hardware decoding in chromium for years. The only issue is with paused videos in chromium which started after they introduced –enable-accelerated-video-decode flag.

I have this issue too. Have you solved it?

After reading wiki again, I solved it by switching from ANGLE driver to system driver, just adding flag “–use-gl=desktop”.