Chromium keeps breaking after updates - startup time of >20 seconds


#1

When I install Manjaro KDE at first Chromium works fine but after a few rounds of updates the browser takes over 20 seconds to start up while before that it starts up in 1-2 seconds. When it starts up you see an icon appear in the taskbar (panel), then the icons disappears and over 20 seconds later the browser finally opens. This is not only with the browser Chromium, it also applies to any browser which uses the engine Chromium, including Brave, Opera and Vivaldi.

After this happened I tried to remove the chromium-folder in ~/.config, that did not help. I had Chromium start up with a flag: “chromium --password-store=basic”. It worked fine after that, only after updates it broke and on a previous installation when I didn’t use the flag it also broke.

The logical questions. Is it known what causes this problem? If not, how can we find the cause?


#2

I think the best thing is to set up kwallet

https://wiki.archlinux.org/index.php/KDE_Wallet

https://wiki.archlinux.org/index.php/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login

https://wiki.archlinux.org/index.php/KDE_Wallet#KDE_Wallet_for_Chrome_and_Chromium

But no idea if that thing is related at all


#3

Sorry i cannot help you to identify what the problem root-cause IS, but i can tell you what it is NOT… it is not some generic/global fault in either Manjaro or the way Manjaro packages [at least some of] those browsers. Reason: MY Vivaldi-Snapshot, Vivaldi-Stable, Chromium [& also FF + FF-Dev.Ed] simply do NOT misbehave like you have described. Never.

Until i read you state that it is not only your Chromium with this symptom, i was thinking that your Chromium profile might be corrupted, & that you might try a virgin profile to test that hypothesis [ie, rename your /home/USER/.config/chromium/Default so you can return to it later, then launch Chromium to let it create a clean profile]. However if all your browsers misbehave, that cannot be it. EDIT: Anyway, you already ruled that out.

Good luck.


#4

To make sure that this is clear, it did also happen to my system on a previous installation of Manjaro KDE. In between I hopped to Manjaro XFCE on which browsers with Chromium engines did not break. Firefox is fine, it is only related to the Chromium engine, my suspicion is that it might have to do with some password system which they use. I guess I could try out whether or not I can get it to work with KWallet if I can figure out how you use that (no experience with that) but even if that would work it would not be a solution for the problem. The browser should work without any password-manager.
[offtopic]I just enter the passwords by hand every time.[/offtopic]


#5

kwallet would just store your keys in the proper way, while your wallet will be unlocked at login.
Im still dubious that its the reason for slow startup or any other issues though.

Are we sure this isnt to do with addons or something like that?
what do you see when starting from the terminal ?


#6

FYI, my Tower’s Vivaldis & Chrome DO use KWallet, but my Lappy’s do NOT. My chromium-based browsers launch equally fast on both machines, despite the KWallet differential. FWIW…


#7

Try to downgrade it to an older version:

Install the program downgrade with sudo pacman -S downgrade.
Then insert the following command in the terminal and hit enter:

sudo DOWNGRADE_FROM_ALA=1 downgrade chromium

It’s important that you write DOWNGRADE_FROM_ALA=1 because otherways it doesn’t work.


#8

Downgrading something like a browser is generally a terrible idea.
Downgrade should also not be used willy-nilly every time you think there is an issue.