Chromium hardware acceleration artifacts Raspberry pi 4

From installation I have had problems with Manjaro (Manjaro-ARM-kde-plasma-rpi4-23.02) that I happily resolved, but I cant manage to fix artifacts on chromium with hardware acceleration turned ON (If its turned off everything works fine, but I want to squeeze every power% out of rpi4).

My problem is that on basically every site I have visual bugs (mismatched icons, 2 comments on any forum overlap etc.)

Raspberry pi: Raspberry Pi 4B 4GB version
OS: Manjaro-ARM-kde-plasma-rpi4-23.02

i have seen this as well recently at someone who ran the gnome/wayland version of manjaro on the pi 4. sometimes it’s not garbage but the youtube player icons getting mixed up

just tried this on my own pi 4 running plasma/x11 and i see the same artefacts

Chromium… Acceleration… Artifacts… when I read these three words I’m almost sure it’s due to Mesa 23.3.3 update.

Try the solution from message #8 and tell us if it’s solved:

@Arrababiski when exactly has the broken version of mesa been published?

i know for sure i have seen this issue on gnome/wayland around december 27th, definitely before december 30th. also the artifacts on the screenshots you have provided in the linked thread don’t look similar to those i have seen. what i have seen was either noise, as can be seen on the screenshot above in this thread here, or all youtube player button icons become volume control icons or otherwise mixed up

i think it’s specific to aarch64 and the broadcom videocore 6 (v3d) gpu because chromium’s hardware acceleration is disabled by default on raspberry pi versions of manjaro.

Mesa 23.3.3 was included in Jan 13 Stable update. I don’t know when was published in Unstable updates. Reading Mesa forum there are a few complaints about things like garbage output, acceleration problems, problems with images, weird color boxes on screen, etc, with 23.3.x versions. They have already published 23.3.4 with bug fixes and I read some people telling 24.0 solved their graphic issues.

Edit: I’ve seen Mesa 23.3.4 is included in Manjaro Jan 25 Testing Update:

Would you all mind testing mesa 23.3.4 and post your experiences.

1 Like

haven’t done an exhaustive test yet but this looks good! :partying_face:

before (mesa 23.1.9 – vulkaninfo):

after: (mesa 23.3.4 – vulkaninfo)

@Darksky you might want to take a look at the different vulkaninfo output because i’ve seen this coming from your version:

WARNING: [Loader Message] Code 0 : terminator_CreateInstance: Failed to CreateInstance in ICD 1.  Skipping ICD.
ERROR: [../mesa-23.3.4/src/panfrost/vulkan/panvk_device.c:381] Code 0 : WARNING: panvk is not a conformant vulkan implementation, pass PAN_I_WANT_A_BROKEN_VULKAN_DRIVER=1 if you know what you're doing. (VK_ERROR_INCOMPATIBLE_DRIVER)

I am not seeing that here on my XFCE install on my pi5. On my Plasma-Wayland install at the moment I am testing the new upstream 6.8.0-rc1 kernel on my pi4 I compiled since RPi has not released it yet. There is no support for the pi5 yet upstream. I have no clue why yours is looking for Panfrost. It should not have to do with anything with the rpi. You would not happen to have vulkan-panfrost installed?

extra/mesa 23.3.2-2 [installed: 23.3.4-1]
extra/vulkan-broadcom 23.3.2-2 [installed: 23.3.4-1]
extra/vulkan-mesa-layers 23.3.2-2 [installed: 23.3.4-1]
extra/vulkan-swrast 23.3.2-2 [installed: 23.3.4-1]

Might be trying to compare apples to oranges with the upstream kernel but here is my outputs using the upstream 6.8.0-rc1 kernel on my pi4:



oh… after unzipping i pressed ctrl+a and hit enter. actually i had installed it because it was in the zip file :see_no_evil: :rofl:

it was a good idea to do btrfs-convert for making a snapshot before trying that out :ok_hand:

After updating Manjaro in mid Jan 2024 chromium pictures displayed in various applications are intermittantly “overlayed” with a block of color. Not all pictures are effected,

I have been having this problem with a very small proportion of pictures on some specific sites. I am running with the MATE desktop on a RPi 5, 8GB, using the Unstable branch. Chromium is currently Version 122.0.6261.39.

Today I found a fix for this problem. I disabled “GPU rasterization” in chrome://flags. Difficult to judge to what extent this slows things down.

While trying different desktops with RPI OS lite, I have found the same problem with “chromium”, but not with “chromium-browser” the RPi custom version. Maybe a clue to a solution to the problem, but beyond my technical capabilities to examine further.