Chromebook Acer CB3-131 Brightness keybindings not working, brightness works using power management tray slider

Trying to find out if I can fix this, Just came from GalliumOS 3.1 due to an ALSA (or Pulseaudio) bug where i cant have persistent alsa settings. Brightness keys worked fine there. I have in the past tried linux mint, but the chromebook keyboard layout wasnt available.

As in title the brightness slider in the system tray (available by right clicking the battery indicator) works fine, but it would be nice if the dedicated keys worked for it. The volume keys, fwd/back, and refresh all work (havent tested the others, assume they all work).

[travis@travis-gnawty ~]$ inxi -Fxxxza
  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=99426514-937b-452a-8937-3b4e9bfaa261 rw quiet apparmor=1 
  security=apparmor resume=UUID=97e78b59-7d1a-45b1-913f-64df0642547d 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 
  vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: GOOGLE product: Gnawty v: 1.0 serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: N/A model: N/A serial: N/A BIOS: coreboot v: N/A date: 12/03/2017 
  ID-1: BAT0 charge: 19.0 Wh (66.4%) condition: 28.6/40.5 Wh (70.6%) 
  volts: 11.5 min: 11.6 model: SANYO AC15A3J type: Li-ion serial: <filter> 
  status: Discharging 
  Info: Dual Core model: Intel Celeron N2840 bits: 64 type: MCP 
  arch: Silvermont family: 6 model-id: 37 (55) stepping: 8 microcode: 838 
  cache: L2: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8671 
  Speed: 1991 MHz min/max: 500/2582 MHz Core speeds (MHz): 1: 1991 2: 2507 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0f31 class-ID: 0300 
  Device-2: Realtek HD WebCam type: USB driver: uvcvideo bus-ID: 1-3:2 
  chip-ID: 0bda:57cf class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 136 size: 256x144mm (10.1x5.7") 
  diag: 294mm (11.6") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 21.2.2 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:0f04 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.37 running: no 
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 1000 
  bus-ID: 01:00.0 chip-ID: 8086:08b1 class-ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus-ID: 1-4:3 chip-ID: 8087:07dc class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Local Storage: total: 130.74 GiB used: 7.28 GiB (5.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/mmcblk1 maj-min: 179:0 vendor: Hynix model: HAG2e 
  size: 14.68 GiB block-size: physical: 512 B logical: 512 B type: SSD 
  serial: <filter> rev: 0x7 scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Lexar model: USB Flash Drive 
  size: 116.06 GiB block-size: physical: 512 B logical: 512 B type: SSD 
  serial: <filter> rev: 1100 scheme: MBR 
  ID-1: / raw-size: 107.8 GiB size: 105.55 GiB (97.91%) 
  used: 7.28 GiB (6.9%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.26 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/sda2 maj-min: 8:2 
  System Temperatures: cpu: 42.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 166 Uptime: 14m wakeups: 1869 Memory: 3.76 GiB 
  used: 1.53 GiB (40.7%) Init: systemd v: 249 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 1048 lib: 304 flatpak: 0 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.06 

I have also tried installing acpilight via pacman, no effect.