Chrome on xfce issues

chrome

#1

I installed google-chrome, launched it, everything was fine, until I forgot to plug the cord and battery died. When I re-booted, chrome doesn’t launch. I tried reinstalling it, no luck.

When using command in terminal: /usr/bin/google-chrome-stable %U or just google-chrome-stable
Cursor jumps to the next line, nothing happens for a half of minute then it shows:

Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files

and nothing more, so I can’t run another command in this terminal window. WTF? What secret service? What is happeining?

The funny thing is, today after anew install, it did started correctly with google-chrome-stable, after turning it off, re-launch is failure with the message above. Chromium and other browsers (vivaldi, firefox) work just fine. So it’s quite possible that the inintial launch for the first time was also showing this pattern and that forced reboot has nothing to do with the situation and chrome just won’t start second time.

On other systems, chrome works well, so there is something specific to this installation.

EDIT: I checked /usr/bin/google-chrome-stable and there is google-chrome-stable file but there is only some variable on how to launch it with flags:

#!/bin/bash

# Allow users to override command-line options
if [[ -f ~/.config/chrome-flags.conf ]]; then
   CHROME_USER_FLAGS="$(cat ~/.config/chrome-flags.conf)"
fi

# Launch
exec /opt/google/chrome/google-chrome $CHROME_USER_FLAGS "$@"

Where do I find a desktop files in xfce? Apart wine desktop files, there is nothing in ~/.local/share/applications

Somehow, xfce gives me more troubles then other DEs. Apart the fact that it works quickly on this old laptop, it’s somewhat disappointing. Other DEs are too heavy for this laptop (it has hdd so… plasma and gnome are too lagging).


#2

Try deleting the cache and/or config for Chrome in your /home/$user/.config|.cache folders.

New profiles often help.


#3

I deleted chrome’s cache and configs. Chrome starts correctly, I did the procedure of syncing, all seems fine. I close it. Try to open it and… the same.

I noticed that it does create processes but no window is visible (about 8-9 processes, like for example: chrome, chrome-sandbox 2x, chrome --type=zygote 2x, nacl_helper, etc.)


#4

So something must be wrong on your Chrome sync.


#5

You’re right. When I launched it clean and didn’t sync, it opens correctly every time. Weirdly, in the first launch, processes didn’t go away, had to manually kill them (background chrome is turned off), but with next re-launch they disappear correctly on closing.

Like I said, I don’t have that issue on other computers.

I googled that weird error message and found this:

https://bbs.archlinux.org/viewtopic.php?id=123644

Installing gnome keyring supposes to fix it but… uninstalling gnome keyring is a fix of the constant password reminder… And I don’t want it so… what to do?


#6

I had a run-in with the Chrome secret service a couple of weeks ago & ended up doing a complete uninstall of Chrome (including cache & related profile file info) - I then reinstalled & synced. I’ve had no problems since.

Try having a look at the post I opened when I was facing a similar issue - you may find something useful.

More power to you.

Ruziel :slight_smile:


#7

I did unintsall chrome, cleaned cache, configs and even desktop files from local/share/applications. Installed, it worked for the two launches, third time, no go… It’s this gnome keyring issue. I have to have it and yet I don’t want to have it…

EDIT: Found solution!

It turned out, when I got rid of gnome keyring, pacman didn’t uninstall gnome keyring lib, gksu and other packages that were messing with chrome. When I got rid of this lib (and other things dependent on it), now chrome starts correctly!

Gnome keyring=evil


#8

Great, I’m glad you found a solution.

Beware the Chrome secret agents!

More power to you.

R.


#9

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.