choose desktop environment broken

when trying to install a new system using manjaro-architect, right after choosing kernel, the "choose desktop environment" list is just broken

getting an error after:

[filter_packages][1] cat: /usr/share/manjaro-architect/profiles/shared/Packages-Root: No such file or directory

Which ISO was used?

the official manjaro architect 20.0 ISO

anyway, I was finally able to make it work by doing the following git clone inside the /usr/share/manjaro-architect folder

git clone -b manjaro-architect --depth 1 https://gitlab.manjaro.org/profiles-and-settings/iso-profiles.git profiles

still, there is something wrong with the latest m-a version

3 Likes

I am having the same issue - using the latest architect iso (architect-20.0-200426-linux56). Can't find a way around it.

1 Like

Thank you for reporting. I'll look into it.

1 Like

I gave up. M-A (or this version of M-A) is an unmitigated disaster. This problem, and then no 'back' anywhere, i have to restart the install over and over because 'cancel' never seems to back you out properly. Zfs 'support' but not really because there is no modules. I tried the propritary video drivers and all my monitors blanked out and I had to restart the install. Then when I do, it shows 'desktop environments' that are nothing but /usr/bin files. I give up. I've spent 4 hours just to try and get snapshots. Maybe I'll try it again in a year when these issues are worked out.

1 Like

Anyway Architect is to perform advance installations.

If you just want to get the operating system installed you can simply get any other ISO, which will provide both Architect and the more easy to use Calamares installer.

Along with a live session you could use to recover your system in case it broke at some point in time.

Latest build was missing the dependency profile-validate. Updated build has been uploaded. You can wait until mirrors are updated or run

sudo pacman -Sy manjaro-architect profile-validate
sudo manjaro-architect
3 Likes

I am still getting "/usr/share/manjaro-architect/profiles/*/dev-null/Packages-Desktop" after following your instructions @Chrysostomus and still have no choices for desktop environments.

2 Likes

Also seeing "/usr/bin/profile-validate: line 163: expac: command not found"

1 Like

Some problem here.
See also these Posts here:

Thank you, I'll look further into it. You can try if installing expac fixes the issue.

I am facing the same issue with freshly downloaded manjaro architect 20.0.
Only 3 options show up in the desktop environments, also after trying the commands you suggested.

Is there a way to meanwhile use an older build of architect 20.0?
The problem seems to appear only within the last days...

1 Like

I think there's no older iso for Manjaro Architect Lysia 20.
You could try the older isos though I believe, have a look here: osdn.
Chrysostomus will certainly fix it in the next hours, at least Architect is an official Manjaro Edition.

After adding expac to the dependencies of profile-validate, it works:

It was an packaging issue, nothing wrong with the installer itself. The reason it is showing only these profiles is that it automatically filters out any profiles that have issues preventing installation.

profile-validate -v                                                                            
pulling isoprofiles
Cloning into '/tmp/profiles'...
remote: Enumerating objects: 219, done.
remote: Counting objects: 100% (219/219), done.
remote: Compressing objects: 100% (143/143), done.
remote: Total 219 (delta 28), reused 158 (delta 5), pack-reused 0
Receiving objects: 100% (219/219), 54.38 KiB | 497.00 KiB/s, done.
Resolving deltas: 100% (28/28), done.

        
Testing profile gnome
Profile gnome passed the test

Testing profile kde
Profile kde passed the test

Testing profile xfce
Profile xfce passed the test

Testing profile awesome
Profile awesome passed the test

Testing profile bspwm
Profile bspwm passed the test

Testing profile budgie
Profile budgie did not pass the test.
The offending packages are: 
          empathy
  
Testing profile cinnamon
Profile cinnamon passed the test

Testing profile deepin
Profile deepin did not pass the test.
The offending packages are: 
          deepin-voice-recorder
  
Testing profile i3
Profile i3 passed the test

Testing profile lxde
Profile lxde passed the test

Testing profile lxqt
Profile lxqt did not pass the test.
The offending packages are: 
          pinta
  
Testing profile mate
Profile mate did not pass the test.
The offending packages are: 
          empathy
  
Testing profile openbox
Profile openbox passed the test


--------------
Following profiles failed the test:
budgie
deepin
lxqt
mate

4 Likes

So, it should be fixed now. I adjusted the broken profiles so they are available again.

1 Like

Works now, thank you! :slightly_smiling_face:

Works here now too. - Thank you for fixing. :slight_smile:

Can we install Manjaro Deepin with Manjaro Architect? I have HP Envy 13 laptop; I try tons of distro to investigate which one is suitable for me and I have an external monitor. I want to use %125 scaling on my laptop and the best suitable DE is Deepin. And absolutely I want to use Deepin DE with the flavour of Manjaro :). Is Deepin DE available?

1 Like

Yes, it is available as minimal and full edition on Manjaro Architect.
Just installed yesterday, works good so far.
Tipp: Change for deepin-kwin WM instead of deepin-wm. deepin-KWIN is more stable.

And be warned, deepin isn't officially supported yet by the Manjaro Team and is under heavy development. Manjaro deepin isn't stable at all at this stage (compare this tread here for details). Thus expect breakages.

And welcome to the forum.

1 Like

Forum kindly sponsored by