Chinese character display box after the latest update

Chinese character display box after the latest update,is a
Problem

1 Like

you can install adobe-source-han-sans-cn-fonts to solve this problem temporarily

What if I want to solve this problem for a long time?

I just found my system doesn't have any chinese font after update. In most cases, adobe-source-han-sans-cn-fonts works. That's all I know.

But this is a problem that occurs after the update.

Do you have noto-fonts-cjk ?
I also have these wqy fonts

[pop@Noo ~]$ pacman -Ss wqy
community/wqy-bitmapfont 1.0.0RC1-1 [installed]
A bitmapped Song Ti (serif) Chinese font
community/wqy-microhei 0.2.0_beta-7 [installed]
A Sans-Serif style high quality CJK outline font
community/wqy-microhei-lite 0.2.0_beta-7 [installed]
The “Light” face of WenQuanYi Micro Hei font family
community/wqy-zenhei 0.9.45-5 [installed]
A Hei Ti Style (sans-serif) Chinese Outline Font.
[pop@Noo ~]$

See if these helps.

encounter same issue after update,
deepin filemanager, chromium bookmark bar display Chinese chars as squares,
deepin-terminal is able to display them correctly, encoding setting:

LC_ADDRESS=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LANG=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_TIME=en_US.UTF-8

BR.

Jonah

yes my chrome display is fine,But the navigation box enters Chinese to display the box.

This is happening for all CJK characters, not just Chinese. There are multiple posts about this issue in 2019-07-17 stable thread. It may be related to ttf-droid or noto-fonts update, and affects KDE, Deepin and Cinnamon(?), but not other desktops (I tried to recreate on Xfce but could not).

But this bug is strange because according to this user, ttf-droid is no longer rendering CJK characters. So it seems to affect KDE desktops that relied on ttf-droid for CJK characters, but also have noto-fonts installed. So what happens if noto-fonts is uninstalled?

@Oroggs @FishHawk @jkuo22 , do you have ttf-droid and noto-fonts installed?

If the user had other CJK fonts other than ttf-droid installed, there is no problem.

There is a bug report on Arch ttf-droid package.

1 Like

I think by enabling the font configs this might create issues when multible fonts are installed. Have to see why the maintainer at Arch enabled configurations for all his fonts he maintains.

1 Like

In one of my manjaro kde, I just have noto-fonts-cjk installed, no wqy fonts and I have no problem.

[pop@Eight ~]$ upd
[sudo] password for pop: 
::信息 下载镜像从 repo.manjaro.org
::信息 使用自定义镜像文件
::信息 查询镜像 - 这可能需要一些时间
  ..... Germany        : http://mirror.ragenetwork.de/manjaro/
  1.405 Germany        : https://manjaro.moson.eu/

The headings in my Firefox also displays well.
Just reporting my situation in case it is useful.

[EDIT] - And in one of my Openbox Manjaro (my own baked OB, not the community OB), I have only the wqy fonts and not the noto-fonts-cjk and I also do not have any problem.

1 Like

same issue here, in my chromium tittle display the box.
scsht_001

yes, I have ttf-droid and noto-fonts installed.

Do I have to install other CJK fonts?

Yes because there is something wrong with ttf-droid. Try noto-fonts-cjk.

1 Like

So when it can be repaired and installed, it can be displayed normally?After all, it can be used before the update.

Here is a bug report and more info why it happens: todo.

It seems that the update has not worked.

Install noto-fonts-cjk to fix.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.