Checking disc image for errors


#1

Noob here,
I tried checking downloaded disc image for errors, as it says in the User Guide on page 19, with no luck.
I have downloaded the image/iso file and also the sha1 file. My problem is in the commands, the commands it gives in the User Guide doesnt seem to work in my terminal.
~$ cd download
~/download ls
These commands do not work in my terminal, however if i put in the commands: cd Downloads, it takes me to the Downloads directory, also when i type in the command; ls, from the Downloads directory it shows me the files inside, so it works this way. And when I enter the command: ~/download$ sha1sum -c manjaro-xfce-17.0-stable-x86_64.iso.sha1, according to what it tells you in the User Guide, it doesnt work for me. It’s here that i’m stuck, i can’t seem to maneuver around a different way of putting in the command, I’m sure its something simple, i just can’t seem to find the right command. Any help would be appreciated, thank you in advance.


#2

You can just type “sha1sum [filename]” and compare that printout with what it is suppose to be.


#3

~/download$ is not a part of the command, it’s supposed to denote what your terminal is displaying. If you break it down, here’s what it means:
~ sysmbol is your home directory
/download is another directory inside it
$ means shell prompt awaiting (regular) user input

The actual command you’re supposed to issue in terminal while being in your Downloads directory is:

For this to work you’re also supposed to download (and put in the same Downloads directory) the manjaro-xfce-17.0-stable-x86_64.iso.sha1 file from the same location you got the .iso from.


#4

And also make sure you put the .iso file in the same folder as the .sha1 file.

If it’s ok, the output should say manjaro-xfce-17.0-stable-x86_64.iso: OK

You might also want to check the signature.

  • download manjaro.gpg (from the bottom of the downloads page) into the same folder as the .iso
  • import the signatures with

gpg --import manjaro.gpg

  • check the signature of the .iso with

gpg --verify manjaro-xfce-17.0-stable-x86_64.iso.sig

It should say that it was

signed with key 11C7F07E and
Good signature from “Philip Mueller (Called Little) philm@manjaro.org


#5

Hey guys, thank you for the response. And thank you for the detailed information, that is greatly appreciated. I have downloaded the .iso and sha1 file into my downloads directory, when i put the command: sha1sum -c manjaro-xfce-17.0-stable-x86_64.iso.sha1, it tells me ‘No such file or directory’. Now that i have the correct commands, thanks to you guys, i think i’m still doing something wrong. I’m wondering, am i supposed to put the sha1 file into my .iso file? I took images of my terminal and file so you see what i’m doing.


#6

You are not in the Downloads directory in your terminal. Either open the terminal from Downloads, or cd Downloads.


#7

The reason I’m checking the disc image errors to remedy my main problem. The laptop I’m doing this on is a Acer Aspire, i did a dual boot of Windows 10 and Manjaro on this, now i want to fully install Manjaro and get rid of Windows, but when put in the USB flashdrive that has the .iso on it, to try and boot from flashdrive, it gives me the error: Failed to load ldlinux.c32
Boot failed: please change disks and press a key to continue.
For some reason the BIOS is not reading my flashdrive. Before i did the dual boot, BIOS would read my flashdrive just fine, thats how i did the dual boot, but now for some reason it doesnt work. I also tried it on my newer laptop, which i also first tried the .iso on and worked fine, but now since downloading this new .iso it doesnt seem to work. Any help with this problem would be great as well, thank you.


#8

Ok I’m back again. Thx for the info, this time i was in the directory, my .iso file is ‘OK’ and i also checked the signature file, i think that is ok as well as it has ‘philm’ signature, however it also says, ‘Cant check signature: No public key’, so i dont know if its good. So if this is all good, the problem with the BIOS not reading my USB flashdrive where i have the .iso, would i need to update my GRUB?


#9

In order to verify the signature you have to import the key first.
You can do it by either downloading and importing the manjaro.gpg file (see my first post), which contains the signatures of all Manjaro developers, or you can download the signature from a keyserver with

gpg --keyserver [keyserver] --recv-key [key]

example: gpg --keyserver pgp.mit.edu --recv-key 11C7F07E

Regarding the other thing, how did you write the iso to the stick? How did you do it when you installed your current system? How did your BIOS recognize it then? Did you do anything differently?


#10

Hi, ok I will try importing the key first, thank you.
As for the BIOS not reading the flashdrive. I downloaded the .iso several months ago, along with Linux Mint and Korora. So I had several USB sticks with different .iso’s on them, and these .iso’s would boot into my old laptop and new one no problem. Since then, I installed Korora on my USB stick, and I use that on my newer laptop no problem. I also wanted to learn more about Manjaro so I decided to do a dual boot on my old laptop, which ran Windows 10. So after doing the dual boot of Manjaro and Windows 10, which I had no problems with, I decided to fully install Manjaro. So from what I read I needed the .iso i had, so i could include my changed partitions into the .iso so i can do the full install. So i put the .iso into my laptop and got that error, so i thought some of the information from the .iso was used in the install, so i went back to Manjaro web page and got another .iso to see if that would fix it. But before i got the new .iso, i tried booting my old ,iso into my new laptop, but it wouldn’t work there either, it wouldn’t read the .iso. So that’s what made me consider that my old .iso was no good anymore after doing the dual boot. So now that i got a new .iso, its doing the same thing, it doesn’t want to boot from the .iso, i just get the error i mentioned earlier, in my new laptop it just doesn’t read the .iso for some reason, when i had my old .iso it worked fine. So i don’t know whats going on. Is there another way of doing a full install not using the .iso? Any info would help, thx.


#11

What tool did you use to write the iso to the usb stick?

These are the steps you have to follow

  1. Download Manjaro .iso, .sha1 and .sig files
  2. Check signature and checksum
  3. Put the .iso onto an usb stick
  4. Boot from the usb stick
  5. Install Manjaro to disc

#12

I used Rufus for all my .iso’s. It seems to be the fastest and most reliable. You know what i think is wrong, i think i need to use a different USB stick to put my .iso on. My Linux Mint .iso is working fine on my new laptop, i havent tried it on my old laptop yet, i will in a bit. The USB stick i have my .iso on could be faulty, i will find out in a bit whether that is the case or not.


#13

You might also want to reformat it (make sure to FAT32).


#14

Ok i imported the signature files and checked it. It says that the signature is good by Philip Muller but as you continue to read it also say, ‘key is not certified with a trusted signature’, so i dont know if its good or not.

Ok i have a question. If i do put the .iso on another USB stick, do i delete the .sha1, .sig, and .gpg files before downloading the .iso on the flashdrive? Or do i keep them files in the directory and download the .iso with them?

Ok overlook my last question, it was a noob question! :stuck_out_tongue:


#15

You can ignore the warning, the signature will only be truly trusted if you met Phil and gave you the signature in person so you can make sure it’s really his.

You have to write/extract (not copy) only the iso to the stick, the rest are only needed for the verification, but you may keep them.
If you are writing the stick from Manjaro (or any other Linux distro), you obviously have to use something else than Rufus. If you don’t want to use a graphical tool, you can also do it from the terminal with the dd command.

sudo dd if=/path/to/isofile.iso of=/dev/sdX bs=4M status=progress && sync

Example:
sudo dd if=manjaro-xfce-17.0-stable-x86_64.iso of=/dev/sdb bs=4M status=progress && sync

if= inputfile - here you have to put the path to and name of the iso file, including the extension. If you navigate the terminal to the folder where the isofile is located, you only have to put the name of the file here.
of= outputfile - you have to put the name of your usb device here. It starts with /dev/sd, and the last letter depends on how many drives you have attached, including all internal and external drives (sda, sdb, sdc, and so on). You can check this with the lsblk command. Be careful, because dd erases all the given drive, so make sure you put the right name here or you will lose data.
bs= block size (optional) - the size of data blocks written to the stick on one go. Some use 1M (megabyte), some suggest 4M, or it can be left out.
status=progress (optional) - if you use this, you will see the progress while data is written
&& sync - it might appear that the writing is finished, but there is still data transfer occurring in the background. Use && sync to avoid removing the stick before the process finished. The process is finished when you get back the command prompt.


Cannot get manjaro disk to boot
#16

Ok thank you for detailed explanation, that helps a lot and very much appreciated. I haven’t tried putting my .iso on another USB stick yet. But now I have another problem, I was just doing a system update, toward the end when It was almost done, it gave me an error, I don’t remember what exactly it said, but it was something about some files already existing. I was using the pacman, so I was going to exit that and update through the terminal, but when I tried clicking on close, it wouldn’t work. I tried clicking on other things but nothing came up, so I did a restart. It went through GRUB, when it was going through its cycle of starting, the screen went dark, but you could see dim lit background going on and off. I thought it was going to start but It never did, it just kept cycling through the dark and dim lit screen. So now I don’t even have a Manjaro OS. What happened? Am I the only one who had this problem occur?


#17

#18

Follow these steps: