Changing Time and Date setting requires Authentication, neither user password nor su password works

My date and time is set to be 2 hours ahead of my actual time for some reason

when trying to change it so it automatically syncs up with my time-zone it shows this prompt for authentication, however neither my user password or the superuser password works

Unfortunately, I can’t tell you why your passwords are not accepted. Could you briefly explain exactly how you tried to change the time?

Regarding the wrong time, I thought about the following. Bucharest falls in time zone UTC +2 during winter time and in time zone UTC +3 during summer time. This could explain the two-hour time difference between the two different time entries. What happens when you enable the option Hardware clock in local time zone? I could imagine that the time is now displayed correctly again.

:arrow_forward: System time - ArchWiki

that also asks me for authentication and gives the same result.

I don’t have a specific answer, but a few ideas:

  • The password would be your password. And a file owned by root is going to be updated.
  • Check the journal (use to be syslog), with journalctl -b0 -r (last boot, in reverse order). See if there are messages dealing with authentication and your userid.
  • Execute the command faillock. If you enter the wrong password (I think the default is 3), you are locked out (I think the default is 10 minutes).