Changes to 40-libinput.conf not working for touchpad speed

kde
boot
libinput
touchpad

#1

every time I boot into my new manjaro kde system i have to manually enter:

input --set-prop 12 'libinput Accel Speed' 1

into the terminal. How do i make this persistent on boot?

I’ve tried editing my /usr/share/X11/xorg.conf.d/40-libinput.conf to read:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "AccelSpeed" "1"
EndSection

but this doens’t work. I’ve also tried entering that first line into my ~/.profile but that doesn’t work either. I don’t want to revert back to synaptics.

thanks for the help.


#2

Plasma 5 does not fully support libinput in X11, and they are not going to either. Full libinput support is not planed until Plasma is running on Wayland, and not before. This is why most of the touchpad features are missing in the KCM when using libinput under X11.


#3

To expand on AJSlye’s reply, installing libsynaptics and x86-input-synaptics should set you on the right road.

GNOME(.org) just seems to go their merry way, regardless of the carnage they leave in their path… :wink:


#4

thank you for the replies. i just assumed that because manjaro installed libinput for me then that was the most up to day “way of doing things”. ill install synaptics and wait out for wayland.

cheers!


#5

You are correct that libinput is the most up-to-date way of setting inputs under Linux, synaptics has long since been in maintenance only mode. Here is an earlier post on the subject:

The issue here is that the KDE team are not focused on supporting libinput under X11, x86-input-libinput is just a wrapper and considered to be not worth their resources to implement code adjustments for.


#6

It’s the same for Qt itself. Xserver is the legacy plattform and nobody wants to implement new features into this. I can totally understand this. Its just a bad situation for some users…


#7

Agreed, and while there is some support for libinput in the kcm-touchpad module, not all are available yet.

https://wiki.archlinux.org/index.php/Touchpad_Synaptics
https://wiki.archlinux.org/index.php/Libinput

There is the option of configuring libinput manually, or using kcm-pointing-devices as an alternative:
https://aur.archlinux.org/packages/kcm-pointing-devices-git/

By the way, have you tried adding or changing that setting in 30-touchpad.conf instead?


#8

no hadn’t considered editing 30-touchpad.conf.

i reverted to synaptics and it works fine now.


#9

Sounds good to me.

I still think making xf86-input-libinput, or any xf86-input-xxx for that matter, a hard dependency for xorg-server was a mistake, but what do I know. :wink:


closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.