Changed keyboard layout - Cannot Sudo

Hi there.

I tried to reset my keyboard lay-out from U.K. to U.S. which I did successfully. The only problem is that now I cannot access Sudo. I am entering the right password as far as I can tell - I tried it out on a text document - but the password isn’t working.

I would appreciate any assistance. I don’t want to log out of the session or restart, in case I get locked out.

Much appreciated.

Ruziel :slight_smile:

Try switching back to UK and change your password to use only a-zA-Z0-9 as chars in your password and try again in the US layout.

Characters that are only available on the UK layout, are not available on the US layout that’s why if your password contains those chars it doesn’t recognize them…

Hi & thanks. That’s the problem. My keyboard was set to the UK & I’m now entering the password based on the U.S. lay-out but it’s not accepting the password. I’ve typed it out on a text document & it is the right password. I’m completely confused. Thanks for your assistance…

PS somehow I have managed to revert it back to the original layout. I will stick with the current UK lay-out.



Because you have problems understanding, let me repeat in steps:

  1. Change back to UK layout.
  2. Change password to ONLY have characters in it from these ranges:
  3. Change to US layout.
  4. Try your password again.

Hi. Thanks, I understand your suggestion - sticking to upper case, lower case & numbers, rather than special symbols as well - I think that’s where I hit the problem. I appreciate the input.