Change the default Arabic font

The Arabic font in Manjaro KDE 18 isn't readable at all. It looks like a calligraphy font than a standard reading one. It is not meant for daily uses.


Reading (at an adult level at least) is not about identifying the order and shape of letters, but rather pattern recognizing a combination of letters semi-instantly give the context of the sentence. Change the default font to "noto naskh arabic font" or any other font that is good for daily uses.

Thank you.

1 Like

The problem here is solved by multiple posts/threads throughout the forum.
One of the problems though is that including the entire noto , for example, is hundreds of megs. Further - in order for them to display correctly without noto it seems to require some 'hacks'.

Arabic/Persian/Urdu font readability fix.
Arabic fonts
Arabic text showing in wrong font
Fonts look terrible with Arabic texts on Manjaro KDE 18.0.4

This is the 'feature request' category so there is somewhat an expectation that you have an actual suggestion.

Do you suggest that noto be included and default? (I rather doubt this will happen)
Do you suggest one of the 'hackish' workarounds be applied by default?
Do you have a better idea?

I don't know why this issue happens in the first place!

Urdu, and Persian fonts look different than Arabic fonts. Arabic fonts looks exactly like English fonts, all capital letters, and small letters has the same heights. Urdu, and Persian looks a little like handwriting.

I prefer option number 2, and I will volunteer to try it if you want to.

Ah .. So, you mean just one or two components of noto be added? This becomes a packaging nightmare very quickly..

Thank you for your reply. Yes I suggest "noto naskh arabic font" to be the default font. Urdu and farsi fonts are not suitable for arabic. I makes skimming and reading far more harder.

1 Like

Just because you deleted the previous post and now made this one - I have to say my reply is above :arrow_up:

I am just Arabian user who like manjaro kde but I found the font is not good for the daily uses. I tried manjaro gnome and ubuntu gnome and kde. This problem doesn't exist there. There are many different fonts that are suitable for daily uses but not this one.

Thank you. :slight_smile:

OK.
Yes - I agree that this is a common enough problem that it should be fixed.
I do not read/write arabic so I am not in a good position to make the fix.
I think if we find a suitable solution that
A - does not destroy fonts for other users
B - does not require expanding the ISO sizes by a large amount
C - does not break packaging
Then we would all be very happy. I honestly do not know what the best solution is.

I will ping some others to make sure the problem is heard.

@jonathon @linux-aarhus @Ste74

@A7mmud Do you think you could maybe try the different 'work-arounds' that exist on the forum that do not rely on noto and report your findings?

Yes. I found a solution here already. But this problem should not exist. It makes it difficult for the newcomers to convert. By the way, I can help to test or even install iso to make things better. It is my pleasure.

What exactly worked for you?
[besides noto]

I cannot remember now. I will check when I go home.

I am maintaining the Openbox Edition.

I can count at least 13 variations of arabic spoken in different countries.

Supporting every single language layout is not only adding to ISO size (in case of CJK 300MB compressed) but also add a plethora of - for other users not using specific languages - irrelevant fonts.

This has been discussed before and while most users like their language fonts to be ready available it is difficult to accommodate with the Manjaro goal of keeping ISO size fitting on a 2GB stick.

I would like know which package solved your issue.

As we have the Manjaro Applilcation Utility we could create a similiar for language dependend font-packages - and integrate it in Manjaro Hello

1 Like

I tried Manjaro for the first time in mid 2018 and saw a lot of posts reporting this issue and its still not fixed...
The problem is only Manjaro got this issue

1 Like

Does that problem solved in 18.1.0 version ?

Sadly the problem is still there Can't believe they still have not fixed it
i think it has been there even before i tried it this is a dealbreaker for me i am switching to Endeavour OS

EDIT: The font is kind of fixed the lock screen shows a normal Arabic font but when you login it's still shows that weird looking font in settings and the clock but in Firefox it shows a normal font not sure if they actually fixing it or it's because i am running it in a VM on a Windows host

1 Like

I hope they fixed it on the latest beta. Someone please confirm. I would like to go back to manjaro KDE.

There is no latest beta, Manjaro KDE 18.1.0 has been released. There are also solutions given which will enable you to use Manjaro KDE with a legible Arabic font which I see you already did once? Leaving over that for another distribution seems a bit odd.

Guys, with respect if you want this issue fixed it will never happen if you move to another distribution and do nothing to help the situation.

Please actively help the manjaro developers by getting involved with testing in future and feeding back such problems. None of them as far as I'm aware read or write Arabic to know the differences and whether or not the problem is resolved by themselves.

You didn't actually bother giving that solution information after all, so you can't expect it to be fixed now.

1 Like

Hello, Thank you for your concern. I really wanted to help but at that time I had a problem when I tried to install nvidia drivers that prevented the whole system to start. Any way I still can help. I will install Manjaro KDE and will help. thank you.

1 Like

Hello. Sorry for the late reply.

After switching to every font. All of them work flawlessly. the problem is the font type. look at the picture bellow to get the idea. Imagine the font in the image is the default one. You cannot deal with it, right?. This is our problem exactly. This how we see this font. It break our experience. Just change the default font. Beginners find it a big deal. So I suggest "Noto Naskh arabic" font or "Droid Naskh shift alt" to be the default one. I hope I helped. Thank you.

1 Like

Hello, I found this reply from another topic that fix the problem. I didn't know this problem is related to Urdu language. 2 lines fixed this. :flushed:

I hope this is fixed in the next release.

@jonathon @linux-aarhus @Ste74 @cscs

Thank you guys.

Forum kindly sponsored by Bytemark