Change of behavior of Power Manager and effect on Xscreensaver

Something has recently changed with Power Manager and Xscreensaver on Manjaro MATE.

My Power Manager Setting in Manjaro MATE:

Power Manager > On AC Power > Display > Put display to sleep when inactive set to Never.

This setting is now ignored.

Previously, this setting has kept Power Management from interfering with a running screensaver.

Now, I doesn’t. Screen now is blanked after 10 minutes even if Xscreensaver has already started a screensaver.

Is there a remedy for this?

I should note that this does not happen with Gnome desktop. XScreensaver still works there. I have not tested the situation with XFCE.

More info. Graphics on Manjaro MATE

dmn@Zotac ~]$ inxi -G
Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
Display: x11 server: 1.20.11 driver: loaded: intel 
unloaded: modesetting resolution: <missing: xdpyinfo> 
OpenGL: renderer: Mesa DRI Intel HD Graphics 2500 (IVB GT1) 
v: 4.2 Mesa 21.0.3

Even if the Power Manager setting is set to a specific time (I tried 1 hour), it is ignored and the screen blanks anyway at 10 minutes of inactivity. So this setting is broken.

Have you ensured that MATE Screensaver does not interfere with Xscreensaver?

Yes, Mate screensaver is uninstalled. Xscreensaver worked until just recently when I noticed the screen blanking unexpectedly after 10 minutes inactivity.

It’s not a problem with xscreensaver, it’s a problem with the power management which is not working correctly.

Also, I didn’t mention that 2 different computers here are affected.

A bit of trivia:

The newest set of xscreensavers now includes a COVID-19 screensaver.

I had the same problem, that the screen is blanking after 10 minutes no matter what.
I’ve found a solution, at least it works for me.
The screen blanking is done by xorg and not the mate desktop or screensavers.

To disable screenblanking you have to use these commands in the terminal as normal user:

xset dpms 0 0 0
xset -dpms
xset s off
xset s noblank

the only downside is that it will NOT stick, so if you logout or reboot and login again you have to enter those commands again!
the workarround to make it permanent is to go to " Control Center / Startup Applications " and add a entry to put those commands in or create a shell script with the commands to run it each time you log in.

This solved the screenblanking for me, after this the screen remains on if you had NEVER selected in power manager.

1 Like