Change mounted drive ownership problems

Been struggling to get games to run under Steam that are intended to run on windows. Native steam games work just fine.

I have an additional SSD I added to give more space for games. Games needing to use proton to run on that drive do not run. I did some looking and notice its an ownership problem.

/bin/sh\0-c\0/jason.directories/home.directories/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=860890 -- /jason.directories/home.directories/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/home/jason/2tbssd/games/steamgames linux/steamapps/common/SteamLinuxRuntime_sniper'/_v2-entry-point --verb=waitforexitandrun -- '/jason.directories/home.directories/.local/share/Steam/steamapps/common/Proton - Experimental'/proton waitforexitandrun  '/home/jason/2tbssd/games/steamgames linux/steamapps/common/Factory Town/Factory Town.exe'\0
chdir "/home/jason/2tbssd/games/steamgames linux/steamapps/common/Factory Town"
ERROR: ld.so: object '/jason.directories/home.directories/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/jason.directories/home.directories/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/jason.directories/home.directories/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/jason.directories/home.directories/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/jason.directories/home.directories/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
wineserver: /home/jason/2tbssd/games/steamgames linux/steamapps/compatdata/860890/pfx is not owned by you
wine: '/home/jason/2tbssd/games/steamgames linux/steamapps/compatdata/860890/pfx' is not owned by you

When I told steam to move that same game to my home directory, it worked.

The drive I have mounted says its mounted as root as well as everything else on the drive.

drwxrwxrwx  1 root  root        4096 Oct 11 23:51  2tbssd

I’ve tried changing the ownership of the mount and it doesn’t change

sudo chown jason:jason /home/jason/2tbssd -R

It still says its owned by root:root

What am I missing?

In case this has anything to do with it, my fstab entry looks like this:

UUID=438CB3774FECC818          /home/jason/2tbssd        ntfs    defaults,noatime 0 0

I’m using this drive for both linux and my windows partition for games.

Thanks

ntfs is a proprietary filesystem that doesnt usually use permissions, and/or usually not in the way you would expect under linux.
(supposedly there are ways to make it do so, but this would carry the cost of interoperability with windoze … which then leaves you asking again why you would do that. If not for windoze, then why use ntfs?)

So … did you do those things to enable nix-like permissions? It would be in the way of a “User Mapping File” or mounting with the permissions option.

Or the more radical question … is there a reason you are using ntfs?

For some more information, including ways to mount the ntfs partition if you really want to keep it, the comments here seem to cover most of the things:

https://askubuntu.com/questions/11840/how-do-i-use-chmod-on-an-ntfs-or-fat32-partition/

2 Likes

I set this up a while back. Looking back at it, I think my plan was to have access to the same drive from both Linux and Windows to install games on it. Maybe I should just create two separate partitions for the windows and Linux games. Thank you for the insight.

An extra comment if you still want that:
To share between the two I might usually suggest exFat.
It has its own caveats, but is usually the easiest to just use shared … like for a data partition.

1 Like

Very helpful. Thank you so much

Jason

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.