Change mount options from Plasma's Removable Devices

Hello everyone, so I’m kinda new on Manjaro and Plasma, I’ll try to give some context before.

I was trying to mount my exFat drive where my games are located, to share it to Steam between Windows and Manjaro, however I did not succeed yet, but that’s for another topic I’ll create later.

I do have many partitions in 3 different drives, almost all of them are exFat formatted, since I do want them to be mounted and the owner user and group be my user, so I tried adding some entries to my fstab file, I tried many options to give the right permissions (in my perspective), so my file ended as follows (just showing some relevant partitions):

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>

UUID=429C2BC99C2BB677 /run/media/erick/WinC auto rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,showexec,utf8,errors=remount-ro,x-gvfs-show 0 0
UUID=1267-D054 /run/media/erick/Games_1 exfat rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,showexec,utf8,errors=remount-ro,x-gvfs-show 0 0
UUID=B833-EA0A /run/media/erick/Sources exfat rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,showexec,utf8,errors=remount-ro,x-gvfs-show 0 0

But with any mount options I tried (even umask=0000) when adding my games partition to my steam library I got failure, in the log said that the access was denied. After searching and reading many posts I found one that said the exfat-fuse was not needed, since exFat support is included in the kernel, so replacing exfat-utils package with exfatprogs will do it.
I replaced it and after a reboot my system didn’t boot, showed errors related to my drives being mounted (sorry I forgot the error messages), so I had just the cli to login, I commented my entries on my fstab file, rebooted and everything stared normally, BUT, all my drives where mounted without problems, with the mount options I gave in fstab, so I tried now to add my partition to the Steam library, worked, my games were the, but still can’t execute them because of permission denied.

I was wondering why my drives are mounted automatically and fount out it was because of Plasma’s Removable Devices application, I unchecked the automount for some devices (on login and on attach) to verify that was the reason, and yes, it was that; but:

  • Now I want to change the mount options for some devices, how can I achieve that in Removable Devices?
  • It seems that Removable Devices uses udisks2, if so, using the udisks2 conf file will do it?
  • I guess the error I had after replacing exfat-utils had to do something with fstab not recognizing the file system, is that true? If so, why? Does fstab still uses exfat-fuse?

If helps, this is some of my output of mount -l:

/dev/nvme1n1p1 on /run/media/Sources type exfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,iocharset=utf8,errors=remount-ro,uhelper=udisks2) [Sources]
/dev/nvme0n1p5 on /run/media/Games_1 type exfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,iocharset=utf8,errors=remount-ro,uhelper=udisks2) [Games_1]
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
portal on /run/user/1000/doc type fuse.portal (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)

so far so good but i’m pretty shure the missing option of “noauto” causes your problem. with noauto it’s possible to mount usb-devices at any time to a designated mout point.
search the net for “fstab usb disk”, there are a lot of examples and tuts how to use it.

ahm … you must read the entire post, but especially this part