CEMU fails to build

Hi all. Using Manjaro again after a while away, and nice to be here again. :slight_smile:

Having a bit of trouble with CEMU, not sure what to do next. It’s in the AUR, so I checked out the relevant AUR page and the maintainer says it’s because we’re using a helper (Pamac?), and this causes the problem. Basically the output states the checksum fails to match on the cemu .zip file, and it fails to build and install.

Not an expert by any means (I just about knew enough to get me this far lol), but is there anything I can do to install this via Pamac? The maintainer recommended manually installing which I did but it still didn’t work (fails to launch). I suppose I could use the standalone binary but I do like the integration when it’s installed into the system, and this did work fine when I last used Manjaro some time ago. Maybe I’m making more of this than it needs lol. /shrugs

Anyway, thanks all.

Welcome here again, @K-Project,

when you tried to install it the “traditional” way, have you done

cd ~
rm cemu.tar.gz
wget https://aur.archlinux.org/cgit/aur.git/snapshot/cemu.tar.gz
tar xzvf cemu.tar.gz
cd cemu
sudo pacman -U cemu-1.22.12-2-x86_64.pkg.tar.zst

I didn’t try the Linux version of CEMU (should be new, I didn’t even know there was one //EDIT: ok it is not a Linux version I looked at the PCKGBUILD), but CEMU in Lutris (Windows version under WINE) works perfectly for me for years now.

Install CEMU from Lutris this way you will have proper WINE version with enhanced features patched, DXVK and other good stuff.

Yes I should have mentioned it’s the Windows version through WINE. Sorry.

Those are the instructions the page has and are indeed the ones I used. I ended up with .dll errors and it failed to launch. I tried 32 and 64 bit profiles on WINE, made sure other .dll’s were installed like DX10, and set the Windows versions to 7 and 10, made no difference.

I’d never heard of Lutris until now however, and upon giving it a go I can see it works fine. I was able to install the newest CEMU into Lutris manually, and get it working that way without any fuss. Literally just done that in a minute. Absolutely brilliant, many thanks. :wink:

The good thing in using Lutris is that you’re using a better WINE version (and you can also install different ones in Lutris, click the Manage Version / Settings icon in the left side menu to check WINE or other Runners), and nothing will break when Manjaro updates WINE, as you’re not using the system WINE (unless you reconfigure CEMU in Lutris to do so). Check CEMU configuration in Lutris you can tweak some stuff there (right click, Configure), it’s pretty advanced.

Also I advice you to use Vulkan API in CEMU, it’s pretty much the best even on Windows.

1 Like

You’re a superstar! Top info, and thanks again for the help. :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.