Can't write to second hard disk

I did some research, found this command 'sudo mount -o remount,rw /dev/sda1' which temporarily works but after a restart everything saved disappears and I still can't make new folders. how to solve this?

You sure this is a technical issue?

There are many guides here on mounting. I'd have a look at them, such as this one:

It is also very easy to set up your hard drives with GUI tools such as Gnome Disks.

Read this:

https://wiki.archlinux.org/index.php/Fstab

mount command only temporarily mounts drives, until reboot. To automatically mount drives at boot, you have to add an entry to the /etc/fstab file. The above link explains how to do that.

If you prefer a video tutorial, look up fstab on YouTube, there are hundreds of videos explaining how to do that.

2 Likes

no, I needed technical assistance. thanks for the post, will read it

Okay, thanks for the info

find UUID of the partion you want to mount by running this command

lsblk -f

Let's say UUID is 2648xyz-abcd , filesystem is ext4 and you want to mount it at /home/johndoe/Data
First make the directory

mkdir /home/johndoe/Data

then add an entry in fstab

UUID=2648xyz-abcd /home/johndoe/Data ext4 rw,users,exec 0 2
2 Likes

I'm pretty hopeless with this kind of thing.
So I install gnome-disk-manager
Then launch 'disks' from the menu.
Then click the square under the disk in question (it means 'stop' or 'unmount' in English)
Then the THIRD tab gives additional partition options....
I generally choose (in Edit mount options) to turn off User Session Defaults, then select the mount point as /mnt/T3 or T4 depending if it's the 3TB Toshiba or the 4TB, and identify as Label=T3 with auto filesystem type.

There is a line of options which I leave as nosuid,nodev,nofail,x-gvfs-show

I haven't edited fstab since 2012.

However, if you open /etc/fstab you can copy it's contents, or copy the file to a backup, and then look at the new version after doing gnome-disks thing - and learn what was done.

1 Like

I did that, but still can't create files on there.

Wow, sorry - I never had that. Did you go in /mnt/T whatever and check ownership/permissions too?

1 Like

I don't have any kind of 'root action' option, also I don't really know how to add permission if I don't have. Didn't have this kind of problem with OpenSuse so sorry if what I'm saying is nonsense

No, but if you browse with Dolphin you can at least see permissions and ownership.

Root actions need to be installed separately (we had a long thread this week about doing sudo gui file browsing stuff - search Dolphin root actions)
Also you can open terminal:

~ >>> /mnt
/mnt >>> la
total 16K
drwxrwxrwx 13 ben root  12K May 28 20:52 T3
drwxrwxrwx 16 ben root 4.0K Jun 26 18:34 T4
/mnt >>>

btw, I set la='ls -lAh'

user: root
group: root
can't change anything.

man chown

Time to start reading the manuals.

tried chown user:group /mnt/folder -R, still nothing

what exactly do you wrote in terminal?

sudo chown .....

and the output from terminal.

1 Like

The simplest example I can think of would be to use Dolphin to go to the folder containing your mounts...
something like /mnt/ is fine.
Then you can hit F4 to get a terminal at the bottom of Dolphin.
Think of a name for your disk folder, then do:
sudo mkdir Disky

Then you'll have a folder called 'Disky' that's owned by Root.

So next you should do 'sudo chown ben Disky'
Then Disky is yours. Then you can go to gnome disks and mount your disk there.

or...
sudo chown hakszi Disky

sudo chown -R hakszi:hakszi /mnt/HDD

1 Like

...
chown: changing ownership of '/mnt/HDD': Read-only file system

Unmount the disk first, just do a folder before mounting.

I moved it to newbies. There were several solutions.
I chose one. No offense, but you lack basic fundamentals.

1 Like

Forum kindly sponsored by