Can't use the headset via BT-Dongle as long as the speakers are pluged in

Hey guys,

I have this problem for about half a year now, hoping it would vanish after some update. Unfortunately it doesn’t ^^ So maybe someone can help me to fix it.

I am using a shokz opencomm headset via the shokz loop 100 BT-dongle, when I need a microphone and not just speakers. For only hearing sound I normally use my desktop stereo speakers, an old bose model, connected via line out (3,5 mm jack).

The problem is, that I can’t change the sound output of system sounds and most other applications to the headset, as long as the bose speakers are connected. I can change them in the audio options, but it doesn’t matter. The sound still comes out of the bose speakers. Only when I disconnect them, the sounds finds it’s way to the headset.
The only exception I am aware of so far is discord. When I change the audio-device in the discord settings, the headset works fine with the bose speakers connected.

Despite the workaround to plug out the speakers isn’t to much of a hassle, it’s starting to annoy me. So I would really appreciate any help to get this problem fixed :grin:

Almost forgot. I’m using manjaro stable, kernel version 5.15.128-1. All up to date at the time of this post.

So let me conclude:

  1. You have 2 sound cards: internal und bluetooth
  2. Internal is set to default and its profile.
  3. BT Headet gets connected, but internal is default.

Correct? Here you need to set the card (device) for each input-sink. That way you can use them in parallel.

It will always set the first connected one as default. So when you connect the BT Headset first, then it must be default and the internal one a fallback.

In pavucontrol you could set the default input/output device and which one is the fallback.

I am very sorry that my reply took so long. I didn’t get a mail that you responded, so I forgot to look for quite some time ^^

  1. I’m not sure, if the bluetooth-dongle comes with a soundcard, too. But that might be the case.
  2. How do I see that? In the settings seems to be no flag for the default device.
  3. That seems to be the case.

I just installed pavucontrol and at least I am now able to hear all sounds via bluetooth, with both devices connected. Setting the default input/output device is something I will try later.

Thank you very much megavolt.