Can't upgrade GCC to version 12

When I try to install many packages, I get:

could not satisfy dependencies:

  • unable to satisfy dependency ‘gcc=10.2.0-6’ required by gcc-ada

If I try to install gcc-git or anything to get to gcc 12, it also gives this error. I’ve tried using add/remove software and -Syyu, but both think I’m up-to-date.

gcc-ada isn’t installed. If I try to install it, I get the same error, but with the recommendation to remove gcc-ada.

If I install and then remove gcc-ada, it doesn’t fix this.

Such as?

GCC 10 is available in the stable repo while 11 is available in the testing and unstable repos.

It’s a build dependency for gcc.

G14-linux and G14-linux-headers (5.12), gcc-git, and several others.

So… just wait for Manjaro to put 12 in the stable/testing/unstable repos?

My understanding is gcc-git is gcc 12, but I can’t install it due to this weird circular dependency or dependency bug.

If gcc-ada is installed as a dependency for gcc, why isn’t it marked as installed in add/remove software?

Yes, as there is no 12 release yet. 11 was just barely released. What you’re calling 12 would be an early, bleeding edge development build that could break at any time.

AUR packages assume one is using a fully up to date Arch system. If you’re going to build bleeding edge packages on Manjaro, use our unstable branch.

1 Like