Can't update Manjaro-alsa and Manjaro -Pulse

I just got a notification for two updates (running KDE) and saw that it was these two packages from the official repositories.

Both were being upgraded from v20210109-1 to 20210928-1

I proceeded with the updates using Pamac and got a message that the updates were applied successfully.

But when Pamac refreshes the updates are still there. And if I check, I still have the older versions of both packages installed.

What’s going on and how do I fix it?

There was some problems with the mirrors a week ago that maybe it wasn’t resolved yet,maybe the update is indeed installed but your mirrors are outdated so the system thinks is not updated and it show the previous version.

Try updating your mirrors

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

It should resolve your issue.

1 Like

Brilliant that fixed it! Thanks

Just out of curiosity, its weird of how the mirrors can notify of an update, but can’t provide an update. I have no idea how any of this works and its voodoo as far as I know, but from an intuitive point of view, it is confusing.

But your solution works, problem solved :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.