Can't Update - lots of errors KDE Manjaro

#17

It is because they removed --force from pacman.

Honestly, I miss it often. There are plenty of situations where --force is a more useful option than --overwrite

#18

yay has a force option, but it is for downloading pkgbuild

overwrite works by stating path, like

sudo pacman -Syyuu --overwrite /usr/share/*

2 Likes
#19

That doesnt answer the more important questions …
have you installed anything manually?
What .iso did you use?
(some of the things in your list shouldnt exist on a normal install)
What is the output of inxi -Fxxxz ?

… this is a rolling release … you should update.
And you must update everything - partial upgrades are not supported.
You can just not update … but you wont get security fixes or anything else that updates offer … and it will mean when you finally do update it will be much larger and complicated.
If you want a ‘fixed’ release distro, you should use something else like ubuntu.

#20

sorry for delay…had to leave the office. I got them to let me back in t finish this

have you installed anything manually?
nothing outside the repo that is Manjaro - AUR was not on.
.iso was KDE Manjaro off the website last month. Manjaro 18.0.4 release
[Stable Update] 2019-03-12 - Kernels, KDE, Deepin, LibreOffice, Nvidia, Browsers, Calamares

we didnt update cause we had everything working after we had to rebuild fresh after several failed updates. we started from scratch on this computer…brand new hard drive and everything.
we thought to wait till all the issues got fixed that were crashing the other ones…through updates.
this PC was held last cause it was working and we needed at least something working to kep us working. the others gt updated ok and so we thought to try now with this one.

seems like the terminal wont show up now…im guessing this now need to reboot…
inxi -Fxxxz was then next thing i was going t post…but no terminal now…brb

#21

Its pretty odd you have packages like libxfce4ui:woman_shrugging:

But, if you really want to just power through you could do something like
sudo pacman-mirrors -f && sudo pacman -Syyuu
Still get the error? Heres the spray-and-pray
sudo pacman -Syyuu --overwrite '*'

[if you cant get a working gui/terminal/etc then you can either try dropping to TTY with CTRL+ALT+F4, or runlevel 3 by hitting ‘e’ at grub selection and putting a 3 with the options - often near ‘quiet’]

#22

This is why I asked if xfce was installed.

#23

sudo pacman -Syyuu --overwrite /usr/*

should do it ya?
spray and pray, :joy: .

for someone who doesnt update a rolling release, whats the worst that could happen. we dont need no stinkin updates!! :roll_eyes:

1 Like
#24

I think you need to do several things in addition to troubleshooting this issue.

  1. What is the hardware we are currently dealing with? Post your inxi -Fzxc0 if you can.
  2. What is the project you are working on?
  3. What is your experience level with linux systems?
  4. What is the reason you are using Manjaro for a production system?
  5. What is the version on your iso?

As to what is causing all of your problems…well at this point it coould be a large number of items. My guess is your iso might be a development version. You have packages with dependencies or version numbers that are conflicting with the update making it impossible to update it. You may very well need to remove the individual packages, clean your cache, perform the update, and then explicitly install the packages you previously removed, but in this case the correct versions. Of course we can’t be sure, because it has all been rather vague so far.

1 Like
#25

crabz - im in the live cd now running the command in a mhwd-chroot # pacman -Syyu
@_@

i got hit with two shoes and a beer can so far…its the only thing i can think to do…i am waiting for the screen to stop loading things then ill get back here and post the output of inxi -Fzxc0
sorry …im trying to focus… lot of people yeling all at once…brb
im telling em its going to be fine

What is the hardware we are currently dealing with? Post your inxi -Fzxc0 if you can.
What is the project you are working on?

this one…
What is your experience level with linux systems?
stated like yesterday kind thing…im not at all gonna say im a beginner cause i seen beginers slap me for being stupid. and i agreed
What is the reason you are using Manjaro for a production system?
production system? not even close…we just get email and do little office stuff right now…cant even surf much…we scream update and everyone goes home …im the guy they say to stay and do the updates…its just updates right?.i kinda know enough install a manjaro from scratch…timeshift and im a guru yes?
What is the version on your iso?

#26

still loading in mhwd-chroot - huge update…betting its gonna go faul…crossing fingers

#27

i keep getting the same question, I have to say that it loaded on systems when others failed and cause it worked then it was pushed to the top of my linux list…never had issues wth the updates till this last month…
now everyone wants me to try ubuntu …i dont want to have to reboot all these computers again…god, really??

#28

still updating in chroot

#29

Yes. The one I posted is just a wildcard for everything* … looking at the list now … it seems /usr/* would have worked.

Kinda common euphemism for folks who use firearms, and/or since the advent of FPS games
It means doing something like this:

#30

i’ve never used nor had to use --overwrite, i was thinking
--overwrite /usr/* would be recursive, but yeah, if it’s not then ?

#31

save me a clip i wanna…i wanna
its still laoding…Ill for sure spray right after if this fails yea?
im afraid to abort now…soo close to the end…

#32

Oops. I misread, I swore yours was /usr/share/ … forget what I said :laughing:
[and edited :wink:]

#33

stop touching it! :face_with_raised_eyebrow:

#34

:grimacing:

#35

sudo pacman -Syyuu --overwrite /usr/*

is that right? ~“loading the gun”~

#36

if that update finishes without errors, do not use that. if it finishes, type exit and reboot