Can't Update Laptop

I hadn’t booted my lapppy in a while. I just built a new computer. So I’ve been using the new one a lot. I booted my laptop and noticed the system was way out of date. I wasn’t surprised. But when I try to update I get this error.

:: Synchronizing package databases...
 core                  146.8 KiB   173 KiB/s 00:01 [----------------------] 100%
 extra                   8.6 MiB   246 KiB/s 00:36 [----------------------] 100%
 multilib is up to date
:: Starting full system upgrade...
:: Replace kauth with extra/kauth5? [Y/n] Y
:: Replace kcoreaddons with extra/kcoreaddons5? [Y/n] Y
:: Replace kitemmodels with extra/kitemmodels5? [Y/n] Y
:: Replace kwindowsystem with extra/kwindowsystem5? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: jdk-openjdk and jre-openjdk are in conflict

What gives? When I was using the machine more regularly, updates went of without a hitch.

You know, it does really pay to read the Stable Updates announcement threads. This question has been asked like 1’000 times already, after the information on how to deal with it was posted to the announcement thread.

sudo pacman -Sy jdk-openjdk && sudo pacman -Syu

It will prompt you to remove the conflicting packages. Answer Y. The jdk-openjdk package will then pull in all the dependencies.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.