can't type the carat glyph (^) in most password field with an AZERTY keyboard

Hello,

I have been trying Manjaro for the past month, coming from Ubuntu for the last 8 years, and this is the last issue that is really bugging me.

So, I have a '^' in a password I use on my system, and I'm using an azerty keyboard (because I'm french), and on every other Linux system I have used, (Debian, Ubuntu, OpenSuse), spanning multiple devices, it as never been an issue.

But on Manjaro, which I only have tried on one of my desktop computer for now, most of the password fields don't support it.

Normally, this key is used to compose other special letter, like ê, â, î and ô. The way you use it is by pressing it (^), then after releasing it, pressing the letter you want. If you just want the character ^ itself, you have to press the key twice.

This works everywhere on the system, in fact I can use it right now to type this message, but on some password prompt, this character can't be inserted by pressing the key twice. The only way I have is by copy-pasting, or virtual keyboard when it's available.

I first tried Manjaro KDE, but decided to go back to Gnome today. The issue affect both system, but not in the same places.

On KDE, I cannot use it to unlock the lockscreen (but can use it to login), and on graphical password prompt, like when launching gparted.

On gnome, I cannot use it on login, lockscreen, and any GUI password prompt.

This does work on terminals (tested with read -s password; echo $password), or when I use a qwerty keyboard.

My google fu has been useless on this one, so if anyone here as any idea on how to attack this problem I'm listening.

PS : the console also as a different issue with this character : when a press the key, the character ^ is inserted right away, preventing me from using the special letter ê, â etc. in the console.

I don't know whether the following will be helpful to you, but I am Belgian and I am also using a keyboard with an a zerty layout, even though there are some small differences between the Belgian keyboard layout and the French keyboard layout.

On my keyboard, there are two caret keys. One is a lowercase key to the immediate right of the p. This is the "dead key" caret, i.e. you have to press it twice to get it to show up, or you press it once, followed by a vowel in order to create a compound character ─ e.g. "ô".

The second caret is on the key with the § in lowercase and 6 in uppercase, but must be formed by holding the AltGr key, and this is a standalone caret ("^"), not intended to be used in combination with another character. So you only need to press it once, while holding down the AltGr key, and then it'll register as a character.

Thanks for the reply. I tried out the belgian layout, where the dead key you describe is the same key on a azerty-french keyboard, location and function.

I also found the second key you describe, and it work as intended. But their is some incompatibility between the two layout, so I would trade switching between qwerty <-> azerty-fr to azerty-be <-> azerty-fr.

The thing that really prevent me to search a fix for this is that it only apply to GUI password prompt, anything else work as intended.

Sorry for the double post.

Just to be clear, event on the Belgian layout, the dead key has the same problem, but not the second key, that is not present on the French layout.

Could you try to use the first key, to reproduce my issue ? If you have the same behaviour, this would tell me that this is not an issue with my setup at least.

I'm sorry, but I cannot afford to log out right now. I am an administrator at two websites and I'm the only staff member on duty there right now. I also have an IRC session open at freenode.net.

But as a workaround, how about changing your password(s) so that it/they do(es) not include any carets?


Addendum: According to Wikipedia, the non-dead caret on a French keyboard is on the alphanumeric key with the characters ç and 9, as per the image below... :arrow_down:

Thanks, I already managed, but don't know how I missed this on my keyboard (I'm not in from of the offending machine right now, maybe it isn't marked on the key ?).

Changing passwords would be possible, but since I have a workaround, this is more of a mild inconvenience, and why I didn't post this in technical issue but here.

To test this, you don't have to log out. I noticed this problem on any popup password prompt, such as when you launch the GUI version of gparted.

Also, I didn't know about the term "dead key", which seems to yield a lot more relevant search results. I'll see if I can fix this with all the new results this evening, when I get back from work.

1 Like

Ok, so after a bit of research I learned about ibus, and that it is not default on arch and manjaro.

A simple sudo pacman -S ibus and restart of the relevant components made the trick.

This made all of the nice integration I'm used to come back as well, like the dead key indicator on all text input.

Forum kindly sponsored by