Can't switch Firefox out of Dark Mode

I have selected a light theme which does change toolbars and tabs to light but menus. preferences, some extensions remain in dark mode. Is there a switch to set everything to light mode? I can’t find it.

Firefox uses the colors defined by the Gtk theme you have set as default in your system. This makes me think that you have set a dark Gtk theme as default.

There are two options:

Select a light Gtk theme for all Gtk-based applications in your system - typically this can be done in the System Settings of your DE.

If you want to keep using a dark Gtk theme and have Firefox using a light theme, the easiest way would be editing its .desktop file.
Copy it from the /usr/share/applications/ directory in ~/.local/share/applications/ (create that folder if it doesn’t exist), open the .desktop file you just copied with a text editor and change the first line beginning with Exec, so that it becomes like this:

Exec=env GTK_THEME=Matcha-sea /usr/lib/firefox/firefox %u

(replace Matcha-sea with the light theme of your choice)

After restarting Firefox, it should use the light theme you set in its .desktop file as default.

In addition, have a look here: