Can't start xdman

I installed xdman through software center from AUR after installation xdman won’t start. Also try to start through terminal with no luck

Welcome to the forum! :wink:

xdman won’t work as a standalone application; it’s a browser extension. Fire up your favorite browser, bring up its extension settings and see whether it’s enabled there. :wink:

Yes I know but it won’t start. Don’t know if I have the right java installed

The PKGBUILD should normally pull in the right dependencies.

Are you getting any error messages when you try that?

actually, it does have a GUI @Aragorn
and this is what happens (for me) when I start it from the terminal:

xdman                                                            ✔ 
[ main ] loading...
[ main ] 15.0.2 5.10.36-2-MANJARO
[ main ] Loading config...
[ main ] Creating folders
[ main ] starting monitoring...
[ main ] Init app
[ main ] Loading fonts
[ main ] Loading language en
[ main ] Context initialized
[ Thread-1 ] Address already in use
	at java.base/ Method)
	at java.base/
	at java.base/
	at java.base/
	at java.base/
	at java.base/
	at java.base/
[ Thread-1 ] instance already runninng
checking for app update
[ Thread-0 ] manifest download response: 200
7.2.11 7.2.11

at this point the GUI appears, after a few seconds delay

I don’t know much about that thing or how it is properly used.
I just installed it to help some guy who had problems with it:

Probleme mit XDMAN

The whole thread is in german, though.

The gist of it is:
I just installed it - it pulled it’s java dependency - and it just started and worked, for me.
As of now, for the other guy as well in the end, apparently.

1 Like

It requires java-runtime>=11. It runs for me with jre-openjdk (provides java-runtime=15)

What Java version(s) do you have installed and which is default? You can check with:

archlinux-java status

See Java - ArchWiki


Thanks it worked on google chrome well
But wont grab video on firefox. even with browser intergration

Thanks its solved am grateful

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.